Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 9556 - linuxconf complains about static-routes option in /etc/dhcpd.conf
linuxconf complains about static-routes option in /etc/dhcpd.conf
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-18 10:56 EST by Ezequiel H Panepucci
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-03 18:24:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ezequiel H Panepucci 2000-02-18 10:56:00 EST
On startup /etc/rc.d/init.d/linuxconf gives the following message
on /var/log/messages:
## removed date/hostname for clarity ##
linuxconf: Linuxconf final setup
linuxconf: Error
linuxconf: Parse error in file /etc/dhcpd.conf, line 6
linuxconf:
linuxconf: ^I  option static-routes 130.132.17.0 172.29.1.2;
linuxconf: ^I                                   ^
linuxconf:
linuxconf: Linuxconf won't be able to use or edit the DHCP
linuxconf: configuration. Please correct.
## end ##

The given option works as regards to dhcpd so I suppose it is correct.
This option takes pairs of IP numbers (destination gateway), the
pairs are separeted by commas, destination is separeted from gateway
by space.

Cheers,
	Zac
Comment 1 Nalin Dahyabhai 2000-04-03 18:24:59 EDT
Does this still occur if you switch to the latest linuxconf from Raw Hide
(ftp://ftp.redhat.com/pub/rawhide/i386/RedHat/RPMS/)?
Comment 2 Brent Fox 2002-06-05 11:54:49 EDT
Closing because we don't ship linuxconf anymore.

Note You need to log in before you can comment on or make changes to this bug.