Bug 956176 - (CVE-2013-2020, CVE-2013-2021) CVE-2013-2020 CVE-2013-2021 clamav: Multiple potential security issues fixed in upstream 0.97.8 version
CVE-2013-2020 CVE-2013-2021 clamav: Multiple potential security issues fixed ...
Status: CLOSED CURRENTRELEASE
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20130423,repor...
: Security
Depends On: 956177 956178
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-24 07:51 EDT by Jan Lieskovsky
Modified: 2015-07-31 03:05 EDT (History)
8 users (show)

See Also:
Fixed In Version: ClamAV 0.97.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-16 09:11:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Lieskovsky 2013-04-24 07:51:01 EDT
Clam AntiVirus upstream has released 0.97.8 version correcting couple of potential security bugs:
[1] http://blog.clamav.net/2013/04/clamav-0978-has-been-released.html
[2] https://github.com/vrtadmin/clamav-devel/blob/0.97/ChangeLog
Comment 1 Jan Lieskovsky 2013-04-24 07:53:33 EDT
These issues affect the versions of the clamav package, as shipped with Fedora release of 17 and 18. Please schedule an update.

--

These issues did NOT affect the version of the clamav package, as shipped with Fedora EPEL 6 (it has been updated to clamav-0.97.8-1.el6 version already).

--

These issues affect the version of the clamav package, as shipped with Fedora EPEL 5. Please schedule an update.
Comment 2 Jan Lieskovsky 2013-04-24 07:54:46 EDT
Created clamav tracking bugs for this issue

Affects: fedora-all [bug 956177]
Affects: epel-5 [bug 956178]
Comment 3 Jan Lieskovsky 2013-04-24 08:00:54 EDT
Request for further issue details:
  http://www.openwall.com/lists/oss-security/2013/04/24/3
Comment 5 Jan Lieskovsky 2013-04-29 03:40:20 EDT
Further issue details (http://www.openwall.com/lists/oss-security/2013/04/27/3):
--------------------------------------------------------------------------------
Hi,

sorry for the delayed response, I'm OOO.

The bugs should be public now:

https://bugzilla.clamav.net/show_bug.cgi?id=7055
heap corruption, potentially exploitable.

https://bugzilla.clamav.net/show_bug.cgi?id=7053
overflow due to PDF key length computation. Potentially exploitable.

https://bugzilla.clamav.net/show_bug.cgi?id=7054
NULL pointer dereference in sis parsing.

When building clamav I recommend disabling legacy or unneeded features
(e.g. sis). I guess that's common sense though.

Cheers
Felix
Comment 6 Jan ONDREJ 2013-04-29 03:45:57 EDT
(In reply to comment #5)
> The bugs should be public now:
> https://bugzilla.clamav.net/show_bug.cgi?id=7054
> NULL pointer dereference in sis parsing.

This last one is still not public.

> When building clamav I recommend disabling legacy or unneeded features
> (e.g. sis). I guess that's common sense though.

Why do you consider, that sis is unwanted? For email scanner any attachment parsing is useful. Even on PC platform user can send an promiscuous .sis file.

Disabling some features can be considered as security bug too, if user knows about features in clamav, but they are disabled in Fedora/EPEL.
Comment 7 Vincent Danen 2013-04-29 16:55:00 EDT
According to http://www.openwall.com/lists/oss-security/2013/04/29/12 :

> https://bugzilla.clamav.net/show_bug.cgi?id=7055
> heap corruption, potentially exploitable.

this is CVE-2013-2020
 
> https://bugzilla.clamav.net/show_bug.cgi?id=7053
> overflow due to PDF key length computation. Potentially exploitable.

this is CVE-2013-2021 (the email above has a typo and also says 2020, which is incorrect; a subsequent email will rectify that typo)

> https://bugzilla.clamav.net/show_bug.cgi?id=7054
> NULL pointer dereference in sis parsing.

This bug is still not public, so no CVE assigned as of yet.
Comment 8 Fedora Update System 2013-05-15 22:52:04 EDT
clamav-0.97.8-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-06-18 02:25:04 EDT
clamav-0.97.8-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-06-20 22:01:24 EDT
clamav-0.97.8-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-06-20 22:06:24 EDT
clamav-0.97.8-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.