Bug 956241 - /etc/os-release is missing in the installer image
/etc/os-release is missing in the installer image
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
19
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 958436 (view as bug list)
Depends On:
Blocks: ZedoraTracker F19Beta/F19BetaBlocker
  Show dependency treegraph
 
Reported: 2013-04-24 10:01 EDT by Dan Horák
Modified: 2013-05-03 21:44 EDT (History)
16 users (show)

See Also:
Fixed In Version: lorax-19.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-03 21:44:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport (44.12 KB, text/plain)
2013-04-24 10:01 EDT, Dan Horák
no flags Details
sosreport (393.29 KB, application/octet-stream)
2013-04-24 10:36 EDT, Dan Horák
no flags Details
sosreport (393.03 KB, application/octet-stream)
2013-04-24 14:03 EDT, Dan Horák
no flags Details

  None (edit)
Description Dan Horák 2013-04-24 10:01:14 EDT
Created attachment 739465 [details]
sosreport

A recent compose for Fedora/s390x fails to switch to the downloaded install.img, please see the attached sosreport.txt
Comment 1 Dan Horák 2013-04-24 10:07:03 EDT
with
dracut-027-19.git20130410.fc19
systemd-202-2.fc19
anaconda-19.20-1.fc19.s390x.rpm
Comment 2 Dan Horák 2013-04-24 10:07:40 EDT
with
dracut-027-36.git20130418.fc19.s390x
systemd-202-2.fc19
anaconda-19.20-1.fc19.s390x.rpm
Comment 3 Harald Hoyer 2013-04-24 10:21:39 EDT
can you add "rd.debug" to the kernel command line?
Comment 4 Dan Horák 2013-04-24 10:36:54 EDT
Created attachment 739473 [details]
sosreport
Comment 5 Dan Horák 2013-04-24 14:03:46 EDT
Created attachment 739564 [details]
sosreport

with
systemd-202-3.fc19
anaconda-19.21-1.fc19
dracut-027-36.git20130418.fc19
Comment 7 Harald Hoyer 2013-04-25 03:49:35 EDT
/dev/mapper/live-rw: LABEL="Anaconda" UUID="db761a5f-bede-4d53-8df0-489163525f2b" TYPE="ext4" 

looks good!

Can you check, if you can do:

# chroot /sysroot
# ldd -r /usr/lib/systemd/systemd

??
Comment 8 Dan Horák 2013-04-25 04:00:39 EDT
:/# ldd -r /usr/lib/systemd/systemd
ldd -r /usr/lib/systemd/systemd 
 libselinux.so.1 => /lib64/libselinux.so.1 (0x000003fffd354000) 
 libsystemd-daemon.so.0 => /lib64/libsystemd-daemon.so.0 (0x000003fffd34e000) 
 libudev.so.1 => /lib64/libudev.so.1 (0x000003fffd33a000) 
 libwrap.so.0 => /lib64/libwrap.so.0 (0x000003fffd32d000) 
 libpam.so.0 => /lib64/libpam.so.0 (0x000003fffd31c000) 
 libaudit.so.1 => /lib64/libaudit.so.1 (0x000003fffd2fc000) 
 libcap.so.2 => /lib64/libcap.so.2 (0x000003fffd2f5000) 
 libkmod.so.2 => /lib64/libkmod.so.2 (0x000003fffd2dc000) 
 libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x000003fffd288000) 
 librt.so.1 => /lib64/librt.so.1 (0x000003fffd27e000) 
 libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x000003fffd26a000) 
 libpthread.so.0 => /lib64/libpthread.so.0 (0x000003fffd24b000) 
 libc.so.6 => /lib64/libc.so.6 (0x000003fffd095000) 
 /lib/ld64.so.1 (0x000002aab04fd000) 
 libdl.so.2 => /lib64/libdl.so.2 (0x000003fffd08f000) 
 libpcre.so.1 => /lib64/libpcre.so.1 (0x000003fffd044000) 
 libnsl.so.1 => /lib64/libnsl.so.1 (0x000003fffd026000) 
 libattr.so.1 => /lib64/libattr.so.1 (0x000003fffd01e000) 
 liblzma.so.5 => /lib64/liblzma.so.5 (0x000003fffcff2000) 
 libz.so.1 => /lib64/libz.so.1 (0x000003fffcfd8000)
Comment 9 Harald Hoyer 2013-04-25 04:23:33 EDT
 /etc/os-release is missing in the anaconda installer image.

If I do:

# cat /etc/os-release > /sysroot/etc/os-release

it works.
Comment 11 Fedora Update System 2013-04-29 16:15:23 EDT
lorax-19.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/lorax-19.3-1.fc19
Comment 12 Fedora Update System 2013-04-30 16:02:46 EDT
Package lorax-19.3-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-19.3-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7050/lorax-19.3-1.fc19
then log in and leave karma (feedback).
Comment 13 Adam Williamson 2013-05-01 14:34:58 EDT
*** Bug 958436 has been marked as a duplicate of this bug. ***
Comment 14 Adam Williamson 2013-05-01 14:35:29 EDT
Transferring blocker status from 958436.
Comment 15 Andre Robatino 2013-05-01 21:22:18 EDT
All four 19 Beta TC2 install images boot properly in VirtualBox, so appears fixed.
Comment 16 Mukundan Ragavan 2013-05-01 21:32:24 EDT
Same here. All good.
Comment 17 satellitgo 2013-05-01 21:40:43 EDT
I just used f19 Beta x86_64 Netinstall selecting basic x plus with gnome, Kde;LXDE;XFCE-session selected in right collumn. It installed to VirtualBox with no problems. All 4 DE's work
I since have used yum install gnome-classic-session and yum groupinstall sugar-desktop
Comment 18 satellitgo 2013-05-01 21:48:16 EDT
gnome-classic and sugar 0.98.7 work
Comment 19 Adam Williamson 2013-05-01 21:50:20 EDT
thanks folks, please up-karma the update!
Comment 20 Fedora Update System 2013-05-03 21:44:15 EDT
lorax-19.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.