Bug 956589 - Wrong dependency management of jbossjts-jacorb artifact
Summary: Wrong dependency management of jbossjts-jacorb artifact
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Maven Repository
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: EAP 6.2.0
Assignee: Paul Gier
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-25 09:26 UTC by Jan Martiska
Modified: 2014-05-22 07:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-10-09 18:31:55 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBTM-1789 Major Open Simplify deploy plugin configuration and don't deploy uber (shaded) jars 2018-11-22 15:11:16 UTC

Description Jan Martiska 2013-04-25 09:26:02 UTC
When working with maven repository zip of 6.1.0.ER5, I found these issues:

$MAVEN_REPO/org/jboss/jbossts/jts/jbossjts-jacorb/4.17.3.Final-redhat-1/jbossjts-jacorb-4.17.3.Final-redhat-1.pom :
- version numbers of dependencies are hardcoded, should be using BOM instead
- there is a dependency on org.hornetq:hornetq-core:2.2.23.Final-redhat-1, which is from 6.0.1 (probably) and cannot be resolved in the 6.1.0.ER5 maven repository

Comment 1 Paul Gier 2013-09-13 14:29:58 UTC
This is caused by the use of the maven shade plugin in the jbossts build.  The shade plugin automatically updates the pom with the dependency versions used while building.

Fixing this would require some significant changes to the upstream build, so it probably won't be fixed until the next major release of JBossTS/Narayana:
https://issues.jboss.org/browse/JBTM-1789

Comment 2 Paul Gier 2013-10-09 18:31:55 UTC
Closing this one as DEFERRED because this is dependent on changes to the upstream Narayana/JBossTS build.  It should be fixed in the next major jbossts upgrade.


Note You need to log in before you can comment on or make changes to this bug.