Bug 957007 - pmchart hangs when being closed
Summary: pmchart hangs when being closed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: pcp-gui
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nathan Scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-26 07:52 UTC by Marko Myllynen
Modified: 2013-11-11 02:37 UTC (History)
3 users (show)

Fixed In Version: pcp-gui-1.5.9-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-02 22:05:30 UTC


Attachments (Terms of Use)

Description Marko Myllynen 2013-04-26 07:52:52 UTC
Description of problem:
pmchart hangs / crashes when it's being closed.

Version-Release number of selected component (if applicable):
pcp-3.6.10-2.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Launch pmchart without any options as a regular user on a host where no PCP daemons are running
2. Click the window manager provided close button
  
Actual results:
Metacity gives pop-up "PCP Charts is not responding" and PCP Information window says:

pmchart: Error: Unable to reuse context to localhost: Attempt to use an illegal context
pmchart: Error: Unable to reuse context to localhost: Attempt to use an illegal context

Expected results:
pmchart closes normally.

Comment 1 Marko Myllynen 2013-04-26 07:56:01 UTC
Clarification, no crash, the window manager just thinks it has hanged because the additional pop-up window opened after closing it.

Comment 2 Nathan Scott 2013-07-26 04:11:00 UTC
This is fixed in upstream commit bb025393aa808e46a313cb4cec97a7007758e0fb.

Comment 3 Fedora Update System 2013-07-28 08:36:18 UTC
pcp-gui-1.5.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pcp-gui-1.5.9-1.fc19

Comment 4 Fedora Update System 2013-07-28 08:50:03 UTC
pcp-gui-1.5.9-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pcp-gui-1.5.9-1.fc18

Comment 5 Fedora Update System 2013-07-28 08:51:21 UTC
pcp-gui-1.5.9-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/pcp-gui-1.5.9-1.fc17

Comment 6 Fedora Update System 2013-07-28 08:52:23 UTC
pcp-gui-1.5.9-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/pcp-gui-1.5.9-1.el6

Comment 7 Fedora Update System 2013-07-28 21:09:52 UTC
Package pcp-gui-1.5.9-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing pcp-gui-1.5.9-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11018/pcp-gui-1.5.9-1.el6
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2013-08-02 22:05:30 UTC
pcp-gui-1.5.9-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-08-16 17:09:31 UTC
pcp-gui-1.5.9-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-09-15 10:24:34 UTC
pcp-gui-1.5.10-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pcp-gui-1.5.10-1.fc18

Comment 11 Fedora Update System 2013-11-01 05:19:59 UTC
pcp-gui-1.5.11-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pcp-gui-1.5.11-1.fc18

Comment 12 Fedora Update System 2013-11-11 02:37:06 UTC
pcp-gui-1.5.11-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.