Bug 957305 - DS instance crashes under a high load
Summary: DS instance crashes under a high load
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Rich Megginson
QA Contact: Sankar Ramalingam
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-27 01:57 UTC by Rich Megginson
Modified: 2013-11-21 21:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Under a very high load (hundreds of simultaneous connections and operations) the directory server could encounter a race condition in the connection handling code. Consequence: The directory server would crash. Fix: Move the code that updates the connection objects inside the connection mutex. Result: Directory server does not crash under high loads.
Clone Of:
Environment:
Last Closed: 2013-11-21 21:07:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1653 normal SHIPPED_LIVE 389-ds-base bug fix update 2013-11-20 21:53:19 UTC

Description Rich Megginson 2013-04-27 01:57:35 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/47349

Under heavy connection load, crashes are being randomly encountered.  This happens because we allocate and set c_private in the connection object after we put the connection on the active list.  Another thread can try to dereference c_private before it is allocated.

Comment 6 Sankar Ramalingam 2013-09-18 11:31:47 UTC
Marking the bugzilla as Verified since no regression found with the latest build - 389-ds-base-1.2.11.15.23.

Comment 7 errata-xmlrpc 2013-11-21 21:07:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1653.html


Note You need to log in before you can comment on or make changes to this bug.