Bug 957546 - fglrx static configuration disables autoprobing for intel driver on muxed system
fglrx static configuration disables autoprobing for intel driver on muxed system
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-28 18:47 EDT by rimbotede
Modified: 2013-04-29 09:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-29 09:44:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
var/log/Xorg* and var/log/messages* (35.41 KB, application/x-7z-compressed)
2013-04-28 18:47 EDT, rimbotede
no flags Details
xorg.conf.d contents (636 bytes, application/x-7z-compressed)
2013-04-28 18:48 EDT, rimbotede
no flags Details

  None (edit)
Description rimbotede 2013-04-28 18:47:08 EDT
Created attachment 741293 [details]
var/log/Xorg* and var/log/messages*

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Easily. Not distro-specific, not specific to the version of catalyst driver currently installed on my system.

Steps to Reproduce:
1. Set BIOS to Integrated graphics only (Intel integrated).
2. Install system.
3. Reboot.
4. Set BIOS to Discrete graphics only.
5. Reboot.
6. Install Catalyst legacy driver (fglrx).
7. Reboot.
8. Set BIOS to Integrated graphics only (Intel integrated).
9. Reboot.
  
Actual results:
Won't boot - stops before loading desktop environment.

Expected results:
Normal boot with Intel integrated graphics working.

Additional info:
Fedora 18, installed clean
Lenovo Thinkpad T500
Intel GMA 4500MHD / ATI Mobility Radeon HD 3650
Comment 1 rimbotede 2013-04-28 18:48:28 EDT
Created attachment 741294 [details]
xorg.conf.d contents
Comment 2 rimbotede 2013-04-28 18:50:42 EDT
Comment on attachment 741293 [details]
var/log/Xorg* and var/log/messages*

The method the logs have been acquired:
sudo rm /var/log/messages* && sudo rm /var/log/Xorg*

THEN, immediately reboot, switch in BIOS to Intel, let system boot and hang.

THEN, switch back to radeon, boot up, put the logs in an archive.
Comment 3 rimbotede 2013-04-28 18:56:49 EDT
The driver I currently use is Catalyst Legacy 13.1 installed per https://ask.fedoraproject.org/question/10924/how-to-install-updated-amd-catalyst-131-for-legacy-chipsets/

The first time I encountered the problem was with Ubuntu 12.04 and Catalyst Legacy 12.6 installed the official way.
Comment 4 Jérôme Glisse 2013-04-29 09:44:26 EDT
It's a closed source driver issue. We can't support fglrx, fglrx bugs should be directed to AMD.

Note You need to log in before you can comment on or make changes to this bug.