Bug 957554 - preupgrade dependancy conflicts with fedup - preventing fedup upgrade path
Summary: preupgrade dependancy conflicts with fedup - preventing fedup upgrade path
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-29 00:47 UTC by Robert Lightfoot
Modified: 2013-05-01 16:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-01 16:43:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Robert Lightfoot 2013-04-29 00:47:57 UTC
Description of problem:
command yum install fedup fails because preupgrade is obseleted by fedup, but PackageKit has a preupgrade dependancy

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. yum install fedup
2. get error
3.
  
Actual results:
install fails

Expected results:
install succeeds

Additional info:
Current Work Around is to remove PackageKit, isntall and run fedup then isntall PackageKit in F19

Comment 1 Robert Lightfoot 2013-04-29 00:49:15 UTC
proposing as beta blocker based on upgrade item in beta release criteria

Comment 2 Robert Lightfoot 2013-04-29 00:55:39 UTC
Fedup-0.7.3-3.fc18.noarch works using the PackageKit removal work around mentioned above.

Comment 3 Adam Williamson 2013-05-01 16:43:29 UTC
Discussed at 2013-05-01 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-01/f19beta-blocker-review-2.2013-05-01-16.01.log.txt . The obsolete was added in 0.7.3-2 and removed again (fixing this bug) in 0.7.3-4 . 0.7.3-2 never made it out of updates-testing; 0.7.3-4 is in there now, so this is effectively fixed (and not a blocker).


Note You need to log in before you can comment on or make changes to this bug.