Bug 957582 - firstboot(setup) asks for 'system register' on an already registered system which has subscription-manager-firstboot uninstalled
Summary: firstboot(setup) asks for 'system register' on an already registered system w...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2013-04-29 05:40 UTC by Rehana
Modified: 2014-11-10 13:55 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-10 13:55:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
firstboot (135.60 KB, image/png)
2013-04-29 05:42 UTC, Rehana
no flags Details

Description Rehana 2013-04-29 05:40:12 UTC
Description of problem:
"Firstboot" setup asks for system registeration, on an already registered system on which "subscription-manager-firstboot" is uninstalled( observed on rhel6.3)

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1.make sure that you have installed subscription manager (1.8) and rhn-setup-gnome 
2.Uninstall subscription-manager-firstboot 
3.register to subscription-manager via cli
4.Launch firstboot and follow through the steps
  
Actual results:
The setup ask to register with (RHN classic or RHN satellite or RHN proxy)(PFA:firstboot.png)

Expected results:
Since the system is already registered, the firstboot setup shouldnot ask to registeration again

Additional info:
when tried launching "firstboot" setup with "subscription-manager-firstboot" installed, it seems to working as expected.

on 
[root@rhel63 ~]# rpm -qa | grep subs
subscription-manager-migration-1.8.6-1.el6.x86_64
subscription-manager-gui-1.8.6-1.el6.x86_64
subscription-manager-debuginfo-1.8.6-1.el6.x86_64
subscription-manager-1.8.6-1.el6.x86_64

[root@rhel63 ~]# rpm -qa | grep rhn-
rhn-check-1.0.0.1-4.el6.noarch
rhn-setup-gnome-1.0.0.1-4.el6.noarch
rhn-setup-1.0.0.1-4.el6.noarch
yum-rhn-plugin-0.9.1-40.el6.noarch
rhn-client-tools-1.0.0.1-4.el6.noarch

Comment 1 Rehana 2013-04-29 05:42:47 UTC
Created attachment 741372 [details]
firstboot

Comment 4 RHEL Program Management 2013-10-14 03:41:45 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 6 RHEL Program Management 2014-11-10 13:55:42 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.