Bug 9577 - CONFIG_2GB breaks initrd
CONFIG_2GB breaks initrd
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-18 21:13 EST by Michael S. Fischer
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-18 21:13:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael S. Fischer 2000-02-18 21:13:54 EST
I've tried to rebuild the stock 6.1 kernel RPM for 2GB RAM support by
replacing the kernel*i686*config files that are provided with the kernel
(changing CONFIG_1GB=y to CONFIG_2GB=y) and rebuilding the binary RPMS.

However, after installing the new RPM on a test system, the kernel refuses
to mount the root device, because the initrd is clobbered at boot -- the
following message appears:

kernel: initrd overwritten (0x80fb4000 < 0x815ba04c) - disabling it.

It's imperative you look at this before 6.2 is released, or that you
document that 6.2 does NOT support 2GB RAM configurations.
Comment 1 Ben LaHaise 2000-10-04 18:06:17 EDT
This is resolved by using the enterprise kernel which contains BIGMEM support
for >1GB.

Note You need to log in before you can comment on or make changes to this bug.