Bug 957755 - gluegen2 is FTBFS on ARM
gluegen2 is FTBFS on ARM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gluegen2 (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Clément DAVID
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-04-29 09:12 EDT by Peter Robinson
Modified: 2013-08-20 04:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 04:30:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2013-04-29 09:12:28 EDT
http://arm.koji.fedoraproject.org/koji/packageinfo?packageID=14668

Not sure if it's missing deps or something else.

c.configure:
gluegen.build.c.impl:
     [echo] Output lib name = gluegen-rt -> libgluegen-rt.so
    [mkdir] Created dir: /builddir/build/BUILD/gluegen-v2.0-rc11/build/obj
     [echo] Compiling src/native/unix/*.c src/native/common/*.c
     [echo] user.dir=/builddir/build/BUILD/gluegen-v2.0-rc11/make
Exception in thread "process reaper" java.lang.StackOverflowError
	at java.io.FileInputStream.readBytes(Native Method)
	at java.io.FileInputStream.read(FileInputStream.java:242)
	at java.lang.UNIXProcess$ProcessPipeInputStream.drainInputStream(UNIXProcess.java:268)
	at java.lang.UNIXProcess$ProcessPipeInputStream.processExited(UNIXProcess.java:280)
	at java.lang.UNIXProcess.processExited(UNIXProcess.java:187)
	at java.lang.UNIXProcess$3.run(UNIXProcess.java:175)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:722)
       [cc] 4 total files to be compiled.
       [cc] cc1: warning: command line option '-fno-rtti' is valid for C++/ObjC++ but not for C [enabled by default]
       [cc] In file included from /usr/include/features.h:399:0,
       [cc]                  from /usr/include/stdio.h:27,
       [cc]                  from /builddir/build/BUILD/gluegen-v2.0-rc11/src/native/common/JVMUtil.c:40:
       [cc] /usr/include/gnu/stubs.h:7:29: fatal error: gnu/stubs-soft.h: No such file or directory
       [cc] compilation terminated.
       [cc] cc1: warning: command line option '-fno-rtti' is valid for C++/ObjC++ but not for C [enabled by default]
       [cc] In file included from /usr/include/features.h:399:0,
       [cc]                  from /usr/include/stdio.h:27,
       [cc]                  from /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9/include/jni.h:39,
       [cc]                  from /builddir/build/BUILD/gluegen-v2.0-rc11/src/native/unix/UnixDynamicLinkerImpl_JNI.c:3:
       [cc] /usr/include/gnu/stubs.h:7:29: fatal error: gnu/stubs-soft.h: No such file or directory
       [cc] compilation terminated.
       [cc] cc1: warning: command line option '-fno-rtti' is valid for C++/ObjC++ but not for C [enabled by default]
       [cc] In file included from /usr/include/features.h:399:0,
       [cc]                  from /usr/include/stdio.h:27,
       [cc]                  from /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9/include/jni.h:39,
       [cc]                  from /builddir/build/BUILD/gluegen-v2.0-rc11/src/native/common/PointerBuffer.c:2:
       [cc] /usr/include/gnu/stubs.h:7:29: fatal error: gnu/stubs-soft.h: No such file or directory
       [cc] compilation terminated.
       [cc] cc1: warning: command line option '-fno-rtti' is valid for C++/ObjC++ but not for C [enabled by default]
       [cc] In file included from /usr/include/features.h:399:0,
       [cc]                  from /usr/include/stdio.h:27,
       [cc]                  from /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9/include/jni.h:39,
       [cc]                  from /builddir/build/BUILD/gluegen-v2.0-rc11/src/native/common/MachineDescriptionRuntime.c:2:
       [cc] /usr/include/gnu/stubs.h:7:29: fatal error: gnu/stubs-soft.h: No such file or directory
       [cc] compilation terminated.
BUILD FAILED
/builddir/build/BUILD/gluegen-v2.0-rc11/make/build.xml:466: The following error occurred while executing this line:
/builddir/build/BUILD/gluegen-v2.0-rc11/make/build.xml:494: gcc failed with return code 1
Total time: 1 minute 20 seconds
Comment 1 Clément DAVID 2013-08-12 05:16:45 EDT
fixed at http://koji.fedoraproject.org/koji/buildinfo?buildID=440297
Comment 2 Clément DAVID 2013-08-12 05:17:41 EDT
the previous issue may be caused by cpptask.

Note You need to log in before you can comment on or make changes to this bug.