Bug 957864 - Simple paged results should support async search
Summary: Simple paged results should support async search
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base
Version: 6.4
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Rich Megginson
QA Contact: Sankar Ramalingam
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-29 18:30 UTC by Noriko Hosoi
Modified: 2013-11-21 21:07 UTC (History)
4 users (show)

Fixed In Version: 389-ds-base-1.2.11.15-22.el6
Doc Type: Bug Fix
Doc Text:
Cause: Simple Paged Results did not supoort asynchronous search. Consequence: If the Directory Server received intensive asynchronous search requests, some of the requests failed and returned error 53 (LDAP_UNWILLING_TO_PERFORM). Fix: Asynchronous search support is implemented. Result: The Directory Server safely handles intensive asynchronous, simple paged result search requests.
Clone Of:
Environment:
Last Closed: 2013-11-21 21:07:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1653 normal SHIPPED_LIVE 389-ds-base bug fix update 2013-11-20 21:53:19 UTC

Description Noriko Hosoi 2013-04-29 18:30:30 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/47347

Some of the intensive asynchronous search requests fail with "unwilling to perform(53), Simple Paged Results Search already in progress on this connection".

Observed in 389-ds-base-1.2.11.15-11.el6.x86_64, but master also has the issue.

In the current code, SPR (simple paged results) is serialized and if a next page request comes in while the current page is being retrieved and returned, it returns 53 to the next page request.

Comment 6 Sankar Ramalingam 2013-08-19 10:29:36 UTC
Hi Noriko,
   To reproduce the issue - I need to run two parallel simple paged search and it should not return error 50. Please correct me if I am wrong.

Comment 7 Nathan Kinder 2013-08-19 14:37:14 UTC
(In reply to Sankar Ramalingam from comment #6)
> Hi Noriko,
>    To reproduce the issue - I need to run two parallel simple paged search
> and it should not return error 50. Please correct me if I am wrong.

The two searches need to be performed on the same connection using async LDAP calls.  You can't reproduce/verify the issue by simply running two separate search clients, as they will be using separate connections.  The original issue was encountered by SSSD, so you could use that as a client.  The alternative is to write a custom test client program.

Comment 8 Sankar Ramalingam 2013-09-11 12:00:40 UTC
Marking the bug as Verified since the associated sssd bugzilla was verified on RHEL6.5.
sssd bugzilla - https://bugzilla.redhat.com/show_bug.cgi?id=951086

Comment 9 errata-xmlrpc 2013-11-21 21:07:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1653.html


Note You need to log in before you can comment on or make changes to this bug.