Bug 957931 - perl-Carp-1.26-242.fc18.noarch remains following fedup f18 --> f19 upgrade
Summary: perl-Carp-1.26-242.fc18.noarch remains following fedup f18 --> f19 upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedFreezeException
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-29 23:40 UTC by Robert Lightfoot
Modified: 2013-06-18 07:10 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-18 07:10:49 UTC


Attachments (Terms of Use)

Description Robert Lightfoot 2013-04-29 23:40:31 UTC
Description of problem:
perl-Carp-1.26-242.fc18.noarch remains following fedup f18 --> f19 upgrade

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Start with default F18 Gnome Desktop Install
2. Upgrade F18 to latest upgrades
3. install fedup-0.7.3-3.fc.noarch
4. run the fedup-cli --network 19 command to it is complete
5. boot f19 system and run yum update taking all approved updates
  
Actual results:
perl-Carp-1.26-242.fc18.noarch remains when rpm -qa | grep fc18 is run

Expected results:
perl-Carp-1.26-242.fc19.noarch should exist and be usable by fedup

Additional info:

Comment 1 Robert Lightfoot 2013-04-30 08:46:53 UTC
I wrote this bug against perl-Carp as they are packaging 1.26-241.fc19 and need to provide a perl-Carp-1.26-242.fc19 package for the F19 release process.  "passing the buck" to fedup when the package doesn't exist and entering no comment or reasoning SHOULD BE UNACCEPTABLE.

Comment 2 Petr Pisar 2013-04-30 09:01:58 UTC
I don't understand who and why needs perl-Carp-1.26-242.fc19. Latest package is  perl-Carp-1.26-241.fc19. Can you explain why we should increase the release number from 241 to 242?

Comment 3 Robert Lightfoot 2013-04-30 09:14:51 UTC
perl-Carp-1.26-242.fc18 is latest for Fedora18 and if perl-Carp-1.26-241.fc19 is latest for Fedora19 then a compare of the two will find the 18 package newer the 19 package and not install the older package.  if 1.26-241.fc18 is not the same as 1.26-241.fc19 asevidenced by the existence of 1.26-242.fc18 then we have a numbering issue.

Comment 4 Petr Pisar 2013-04-30 10:32:01 UTC
I see. It's because F18 got perl updates after removing the perl-Carp sub-package from F19 and fedup does not do `yum distro-sync'.

I'll try to identify all such cases and remove them from F18 and increase releases of standalone packages to supersede them.

Comment 5 Petr Pisar 2013-04-30 11:34:40 UTC
There is or can emerge NEVRA regression with these perl sub-packages between F18 and F19:

perl-Carp
perl-ExtUtils-Manifest
perl-parent
perl-Test-Simple-tests
perl-Test-Simple
perl-threads
perl-Version-Requirements

Comment 6 Fedora Update System 2013-04-30 12:26:05 UTC
perl-Carp-1.26-243.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perl-Carp-1.26-243.fc19

Comment 7 Fedora Update System 2013-04-30 12:28:42 UTC
perl-Carp-1.26-243.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-Carp-1.26-243.fc18

Comment 8 Adam Williamson 2013-05-01 17:02:31 UTC
Petr: note that there is an autoqa test that checks this for you. It's called 'upgradepath'. When the upgradepath test fails on a build you do, it is warning you that you're getting into this situation (higher NEVR on an older release).

Discussed at 2013-05-01 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-01/f19beta-blocker-review-2.2013-05-01-16.01.log.txt . Upgrade path issues are not in and of themselves freeze exceptions; they're only a big problem if they cause problems with the upgrade. This kind of thing can always be fixed with a later update. Rejected as a freeze exception.

Comment 9 Kalev Lember 2013-05-03 10:39:58 UTC
Looks like at least one more package needs bumping, perl-Digest:

Error: Package: perl-Digest-1.17-242.fc18.noarch (@updates/18)
           Requires: perl = 4:5.16.3-242.fc18
           Removing: 4:perl-5.16.3-242.fc18.x86_64 (@updates/18)
               perl = 4:5.16.3-242.fc18
           Updated By: 4:perl-5.16.3-262.fc19.x86_64 (fedora)
               perl = 4:5.16.3-262.fc19

Comment 11 Fedora Update System 2013-05-09 18:48:27 UTC
perl-Digest-1.17-244.fc19, perl-Carp-1.26-243.fc19, perl-ExtUtils-Manifest-1.61-243.fc19, perl-Version-Requirements-0.101022-243.fc19, perl-threads-1.86-243.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-05-21 08:46:46 UTC
perl-5.16.3-244.fc18, perl-Digest-1.17-244.fc18, perl-Carp-1.26-243.fc18, perl-ExtUtils-Manifest-1.61-243.fc18, perl-parent-0.225-243.fc18, perl-Test-Simple-0.98-243.fc18, perl-Version-Requirements-0.101022-243.fc18, perl-threads-1.86-243.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.