Bug 958276 - videos without audio might not be played after migration (till client reconnects)
Summary: videos without audio might not be played after migration (till client reconne...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Yonit Halperin
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 952671
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-30 19:31 UTC by Yonit Halperin
Modified: 2017-02-06 15:16 UTC (History)
7 users (show)

Fixed In Version: spice-server-0.12.3-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: On migration, the destination host does not send the client its multi-media time (does not send MSG_MAIN_INIT). Consequence (from comment #0): If there is no audio playback, and the 2 hosts that are involved in migration have different uptime, the client that is connected during migration, holds the multi-media time of the source server. Then, video frames that are created after migration (and thus hold the destination mm-time), are dropped by the client. Fix: Make destination host send multi-media time after migration. Result: Video without audio now plays successfully.
Clone Of:
Environment:
Last Closed: 2013-11-21 07:41:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1571 normal SHIPPED_LIVE spice-server bug fix and enhancement update 2013-11-20 21:39:57 UTC

Description Yonit Halperin 2013-04-30 19:31:21 UTC
Description of problem:
If there is no audio playback, and the 2 hosts that are involved in migration have different uptime, the client that is connected during migration, holds the multi-media time of the source server. Then, video frames that are created after migration (and thus hold the destination mm-time), are dropped by the client.

Disconnecting and reconnecting the client will eliminate the inconsistency.

How reproducible:
(1) VM without audio device (I'm not sure that just muting the sound will stop sending audio frames to the client).
(2) connect a client to the vm
(3) migrate between 2 hosts with significantly different mm-time
(4) play video.
    An alternative to (1) is to play a video without a soundtrack.

Additional info:
When there is a soundtrack, the client updates it mm-time by using the audio frames mm-time.
This bug is complementary to bug #951664

Comment 10 errata-xmlrpc 2013-11-21 07:41:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1571.html


Note You need to log in before you can comment on or make changes to this bug.