Bug 958387 - Large memory allocation per request in drools-camel-server
Summary: Large memory allocation per request in drools-camel-server
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: BRE
Version: 5.x.x
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ER5
: 6.0.0
Assignee: Mario Fusco
QA Contact: Radovan Synek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-01 09:41 UTC by Toshiya Kobayashi
Modified: 2018-11-30 20:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 882155
Environment:
Last Closed: 2013-12-12 09:33:57 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker JBRULES-3699 0 Major Open Large memory allocation per request in drools-camel-server 2015-09-09 13:15:17 UTC

Comment 5 Edson Tirelli 2013-09-06 12:47:01 UTC
Mario, can you please take a look at this one? Is this still happening in 6?

Comment 6 Mario Fusco 2013-10-02 08:50:49 UTC
As evidenced by Toshiya the biggest part of this memory occupation is caused by the conversion of InputStreams to Strings. Unfortunately I don't think this is avoidable. Moreover there are many ways to perform this conversion, but as for example reported here:

http://www.journaldev.com/706/how-to-convert-inputstream-to-string-in-java

we are apparently already using the most memory efficient one.

I can't find a way a to improve this issue but any other suggestion is welcome.

Comment 10 Radovan Synek 2013-12-12 09:33:57 UTC
closed as won't fix, see comment 6.


Note You need to log in before you can comment on or make changes to this bug.