This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 9584 - PCMCIA throws a kernel oops on Compaq LTE 5100
PCMCIA throws a kernel oops on Compaq LTE 5100
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-19 03:59 EST by Justin Husted
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-19 03:59:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Husted 2000-02-19 03:59:37 EST
I tried to upgrade my laptop to 6.1, and the network boot disk failed.
It would throw a kernel oops on starting pcmcia and basically die.
Unfortunately, it's kind of hard to get useful information out of the
system when the installer's going.

(BTW, 6.0 worked fine, AND 6.2beta seems to work with pcmcia)

Anyway, I tried upgrading manually, and was able to reproduce it after
installing the 6.1 kernel / pcmcia tools.

Output is as follows:

[root@soro /root]# /etc/rc.d/init.d/pcmcia start
Starting PCMCIA services: modules cardmgr.
cardmgr[100]: starting, version 3.0.14
[root@soro /root]# cardmgr[100]: watching 2 sockets
cardmgr[100]: initializing socket 0
cardmgr[100]: socket 0: SVEC 10/100 Fast Ethernet
cardmgr[100]: executing: 'insmod
/lib/modules/2.2.12-20/pcmcia/cb_enabler.o'
cardmgr[100]: executing: 'insmod /lib/modules/2.2.12-20/pcmcia/tulip_cb.o'
Oops: 0000
CPU:    0
EIP:    0010:[<c3040f04>]
EFLAGS: 00010246
eax: 00000000   ebx: c27c6ae0   ecx: c1638120   edx: 00000000
esi: 00000000   edi: x2107000   ebp: c216fad8   esp: c216fad0
ds: 0018   es: 0018   ss: 0018
Process cardmgr (pid: 100, process nr: 12, stackpage=c216f000)
Stack: c1638120 c2107000 c216faec c30418a7 c1638120 00000000 00000000
c216fb6c
       c30542e9 0000002d c1638120 00000000 c1638240 00000000 c30546e0
6e000000
       c30546e0 c216fb00 00000000 00000032 00000032 00000032 49434d43
74450041
Call Trace: [<c30418a7>] [<c30542e9>] [<c30546e0>] [<c30546e0>]
[<c30544ed>] [<c305444c>] [<c30406df>]
        [<c304a139>] [<c3041aee>] [<c3041827>] [<c3054152>] [<c30546e4>]
[<c305444c>] [<c3042ab8>] [<c305405a>]
        [<c30514f0>] [<c01a47cd>] [<c3051fa9>] [<c01964b7>] [<c0197bd7>]
[<c0198f66>] [<c019705f>] [<c019a1db>]
        [<c019eca9>] [<c019e22b>] [<c019e41b>] [<c011cc3f>] [<c011c58a>]
[<c011c8e1>] [<c012e6a1>] [<c0109d08>]
Code: 8b 56 04 f6 c2 05 75 0d 66 83 7e 0a 00 74 0d f6 46 0c 05 74


I can't really run a ksymoops on this easily, since the system is kind of
munged.  Here are the modules installed:

tulip_cb
cv_enabler
ds
i82365
pcmcia_core
loop
opl3
sb
uart401
sound
soundlow
soundcore

Interrupts:
 0 timer
 1 keyboard
 2 cascade
 5 soundblaster
 8 rtc
13 fpu
14 ide0

IO ports:
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
01f0-01f7 : ide0
0220-022f : soundblaster
0330-0333 : MPU-401 UART
0388-038b : Yamaha OPL3
03c0-03df : vga+
03e0-03e1 : i82365
03e8-03ef : serial(auto)
0df6-03f6 : ide0
03f8-03ff : serial(auto)

If you need more information, like a valid ksymoops spew, I'll be able
to extract something given some more effort.

Note You need to log in before you can comment on or make changes to this bug.