Bug 958452 - dnf update Produces Log Messages Involving "ts_done state"
dnf update Produces Log Messages Involving "ts_done state"
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-01 10:13 EDT by Garry T. Williams
Modified: 2014-09-30 19:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: dnf-0.3.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 04:47:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Command line + log messages (15.85 KB, text/plain)
2013-05-01 10:13 EDT, Garry T. Williams
no flags Details

  None (edit)
Description Garry T. Williams 2013-05-01 10:13:35 EDT
Created attachment 742221 [details]
Command line + log messages

Description of problem:
Whenever I run dnf update, the cleanup stage always produces log messages like these:

May 01 09:22:59 vfr yum[6737]: Updated: espeak-1.47.07-1.fc18.x86_64
May 01 09:23:00 vfr yum[6737]: Updated: emacs-filesystem-1:24.2-18.fc18.noarch
May 01 09:23:00 vfr yum[6737]: emacs-filesystem-1:24.2-6.fc18.noarch: ts_done state is emacs-filesystem-1:24.2-6.fc18.noarch 90 should be install xscreensaver-base
May 01 09:23:00 vfr yum[6737]: emacs-filesystem-1:24.2-6.fc18.noarch: ts_done name in te is xscreensaver-base should be emacs-filesystem-1:24.2-6.fc18.noarch
May 01 09:23:00 vfr yum[6737]: xscreensaver-extras-1:5.21-2.fc18.x86_64: ts_done state is xscreensaver-extras-1:5.21-2.fc18.x86_64 90 should be install xscreensaver-extras-base
May 01 09:23:00 vfr yum[6737]: xscreensaver-extras-1:5.21-2.fc18.x86_64: ts_done name in te is xscreensaver-extras-base should be xscreensaver-extras-1:5.21-2.fc18.x86_64
May 01 09:23:01 vfr yum[6737]: xscreensaver-gl-extras-1:5.21-2.fc18.x86_64: ts_done state is xscreensaver-gl-extras-1:5.21-2.fc18.x86_64 90 should be install mysql-libs
May 01 09:23:01 vfr yum[6737]: xscreensaver-gl-extras-1:5.21-2.fc18.x86_64: ts_done name in te is mysql-libs should be xscreensaver-gl-extras-1:5.21-2.fc18.x86_64
May 01 09:23:02 vfr yum[6737]: mysql-server-5.5.30-1.fc18.x86_64: ts_done state is mysql-server-5.5.30-1.fc18.x86_64 90 should be install xscreensaver-gl-base
May 01 09:23:02 vfr yum[6737]: mysql-server-5.5.30-1.fc18.x86_64: ts_done name in te is xscreensaver-gl-base should be mysql-server-5.5.30-1.fc18.x86_64


Version-Release number of selected component (if applicable): F18,
$ dnf --version
0.2.23
  Installed: dnf-0:0.2.23-1.git50db212.fc18.noarch at 2013-03-24 11:51
  Built    : Fedora Project at 2013-03-21 12:43

  Installed: rpm-0:4.10.3.1-1.fc18.x86_64 at 2013-02-12 13:56
  Built    : Fedora Project at 2013-02-06 09:54
$


How reproducible: Always


Steps to Reproduce:
1.  Run "dnf update"
2.  Examine system log
3.
  
Actual results:
Messages about ts_done state


Expected results:
No messages in log


Additional info:
Comment 1 Ales Kozumplik 2013-05-02 02:54:19 EDT
Thank you for the report, Garry.

Testing with dnf-0.3.3 this is still an issue, I see entries like:

May 02 08:14:53 INFO gnome-shell: ts_done state is gnome-shell 90 should be install gnome-shell

in /var/log/dnf.rpm.log (was dnf.transaction.log)

Incidentally, I'm in the process of redesigning the transaction management/reporting in DNF so I will make sure this problem goes away along with that work.

The good thing is that these seem to be only errors in transaction reporting and your packages and RPMDB are fine.
Comment 2 Garry T. Williams 2013-05-02 07:47:36 EDT
(In reply to comment #1)
> The good thing is that these seem to be only errors in transaction reporting
> and your packages and RPMDB are fine.

Yes.  I should have mentioned that in my report.
Comment 3 Ales Kozumplik 2013-05-13 04:47:58 EDT
I've merged the transaction overhaul branch to the master branch now. The ts_done() is not used anymore and so the transaction log is free of the error messages (yet describes in detail all the changes that happened to the RPMDB).

The main purpose of ts_done() was transaction journaling introduced by commit 13fa959a. It doesn't reference a bugzilla number and since the libsolv depsolver below DNF can resolve operations very quickly I see little value in keeping the journaling/redoing functionality around and I have no plans at the moment to reenable these in DNF. This might change if substantial argument in defense of journaling is given in the future.

Thanks for the report, closing this.

Note You need to log in before you can comment on or make changes to this bug.