Bug 958496 - [uplift] List of supported installation environments is stale -- needs later Fedora, Debian, etc
Summary: [uplift] List of supported installation environments is stale -- needs later ...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Kletzander
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-01 16:30 UTC by R P Herrold
Modified: 2013-11-21 10:37 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-11-21 10:37:49 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1604 normal SHIPPED_LIVE python-virtinst bug fix and enhancement update 2013-11-20 21:39:12 UTC

Description R P Herrold 2013-05-01 16:30:22 UTC
Description of problem:

 The list of supported installation environments is painfully stale -- needs later Fedora, Debian, etc

Version-Release number of selected component (if applicable):

virt-manager-0.9.0-18.el6  (most recent current)


How reproducible:

do an install and look at offerings -- out of support Fedora only ;)


Steps to Reproduce:

as above  


Actual results:

lots of stale stuff, and recent: no Debian (7), no Fedora after F 16, Ubuntu  back in 2011, SuSE in the 11 series ... 

Expected results:

a current collection

Additional info:

the prior 'support matrix' link, noted back in RHEL 6.1 beta days, has rotted -- noted in  https://bugzilla.redhat.com/show_bug.cgi?id=678790

but this points up a need for systematic review on the list from time to time

Comment 2 Martin Kletzander 2013-05-22 13:07:01 UTC
Moving to POST as more current versions were added in following commits.  You are missing some of those versions as you have older virt-manager than latest available, I believe there was an update of thos in newer RHEL.

commit fb76c4e550006cf3948106852228198255f1983e
Author: Marc Deslauriers <marc.deslauriers@canonical.com>
Date:   Tue May 21 16:00:41 2013 -0400

    virt-manager: Update list of Ubuntu releases

commit e5cc1b8e20d790ea309b37ad21ce395c30c5abfb
Author: Cole Robinson <crobinso@redhat.com>
Date:   Sun Oct 14 16:17:37 2012 -0400

    osdict: Add Fedora 18

commit ed0b7fa4a44e85070c34952e68089e6d94b2f230
Author: Cole Robinson <crobinso@redhat.com>
Date:   Sun Jul 8 17:17:55 2012 -0400

    Add RHEL7 to osdict

commit f9ed4e76821521e3a6de0477d20dddf2987af4a5
Author: Marc Deslauriers <marc.deslauriers@canonical.com>
Date:   Mon Apr 23 09:57:15 2012 -0400

    virtinst: Add latest Ubuntu releases

Comment 7 hyao@redhat.com 2013-07-04 03:35:13 UTC
Reproduce the bug on 6.3 with the following packages
virt-manager-0.9.0-14.el6.x86_64
libvirt-0.9.10-21.el6.x86_64

Comment 13 hyao@redhat.com 2013-07-22 09:46:01 UTC
the bug is fixed on the following packages:

rpm -qa libvirt virt-manager python-virtinst
python-virtinst-0.600.0-17.el6.noarch
virt-manager-0.9.0-18.el6.x86_64
libvirt-0.10.2-21.el6.x86_64

# rpm -qa libvirt virt-manager python-virtinst
libvirt-1.1.0-1.el7.x86_64
virt-manager-0.10.0-1.el7.noarch

Comment 14 errata-xmlrpc 2013-11-21 10:37:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1604.html


Note You need to log in before you can comment on or make changes to this bug.