Bug 958522 - loading an entry from the database should use str2entry_fast
Summary: loading an entry from the database should use str2entry_fast
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Rich Megginson
QA Contact: Sankar Ramalingam
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-01 18:04 UTC by Noriko Hosoi
Modified: 2013-11-21 21:07 UTC (History)
3 users (show)

Fixed In Version: 389-ds-base-1.2.11.15-22.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 21:07:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1653 normal SHIPPED_LIVE 389-ds-base bug fix update 2013-11-20 21:53:19 UTC

Description Noriko Hosoi 2013-05-01 18:04:20 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/531

When loading an entry from the backend it is known to be well formed and str2entry_fast() could be used, but always str2entry_dupcheck() is called.
The reason is that id2entry() sets the flag SLAPI_STR2ENTRY_NO_ENTRYDN and this flag is not contained in the set of flags known to be handled by str2entry_fast() although it does have code for this flag

Comment 6 Sankar Ramalingam 2013-09-02 10:49:28 UTC
Sanity only verification. Marking the bug as Verified since no regressions found.

Comment 7 errata-xmlrpc 2013-11-21 21:07:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1653.html


Note You need to log in before you can comment on or make changes to this bug.