Bug 958611 - Fatal server error: [ 750.103] EnterVT failed for gpu screen 0
Summary: Fatal server error: [ 750.103] EnterVT failed for gpu screen 0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 19
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-02 04:18 UTC by Ankur Sinha (FranciscoD)
Modified: 2013-05-15 03:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-15 03:47:57 UTC
Type: Bug


Attachments (Terms of Use)
Xorg.0.log (36.82 KB, text/x-log)
2013-05-02 04:18 UTC, Ankur Sinha (FranciscoD)
no flags Details
suspend/resume log (8.86 KB, text/x-log)
2013-05-02 04:19 UTC, Ankur Sinha (FranciscoD)
no flags Details
relevant portion of /var/log/messages showing X errors (9.27 KB, text/x-log)
2013-05-02 04:20 UTC, Ankur Sinha (FranciscoD)
no flags Details
An older X log (44.92 KB, application/octet-stream)
2013-05-02 04:21 UTC, Ankur Sinha (FranciscoD)
no flags Details


Links
System ID Private Priority Status Summary Last Updated
FreeDesktop.org 59190 0 None None None Never
FreeDesktop.org 62916 0 None None None Never
Red Hat Bugzilla 955400 0 unspecified CLOSED Upgrading to 1.14.0-6.fc19.x86_64 breaks X 2021-02-22 00:41:40 UTC

Internal Links: 955400

Description Ankur Sinha (FranciscoD) 2013-05-02 04:18:11 UTC
Created attachment 742460 [details]
Xorg.0.log

Description of problem:
When I resume my system from hibernate, X fails to start. This causes gdm to come back up, killing whatever gui applications were running. I run an instance of byobu/screen, and on logging back in, this is still available as a detached instance, showing that the hibernate did indeed save state. 

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.14.0-3.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1.hibernate system
2.resume from hibernate
3.
  
Actual results:
Gdm comes up again. All GUI applications have been killed.

Expected results:
System should resume with gui applications in tact

Additional info:
I haven't updated to 1.14.0-6 since it completely breaks X for me. Bug filed already:
https://bugzilla.redhat.com/show_bug.cgi?id=955400

This bug seems to be in 1.14, was ok with 1.13. Upstream bug with a patch here:
https://bugs.freedesktop.org/show_bug.cgi?id=62916

https://bugs.freedesktop.org/show_bug.cgi?id=59190

It'll be great to have this fixed.

Comment 1 Ankur Sinha (FranciscoD) 2013-05-02 04:19:45 UTC
Created attachment 742461 [details]
suspend/resume log

Comment 2 Ankur Sinha (FranciscoD) 2013-05-02 04:20:27 UTC
Created attachment 742462 [details]
relevant portion of /var/log/messages showing X errors

Comment 3 Ankur Sinha (FranciscoD) 2013-05-02 04:21:09 UTC
Created attachment 742463 [details]
An older X log

Comment 4 Ankur Sinha (FranciscoD) 2013-05-02 19:55:33 UTC
Looks like it's related to https://bugzilla.redhat.com/show_bug.cgi?id=955400

Using the work around that Dave gave there, this no longer happens. My X server comes up OK after a hibernate.

Comment 5 Dave Airlie 2013-05-15 01:51:31 UTC
is this still a problem with the latest F19 X server if you remove the workaround?

Comment 6 Ankur Sinha (FranciscoD) 2013-05-15 03:47:57 UTC
(In reply to comment #5)
> is this still a problem with the latest F19 X server if you remove the
> workaround?

Hi Dave, 

Seems to be fixed now. Moved the workaround and X came up just fine. Closing.

Thanks for looking into it so quickly :)

Warm regards,
Ankur


Note You need to log in before you can comment on or make changes to this bug.