Bug 958642 - CVE-2013-2037 Python httplib2: ssl cert incorrect error handling [epel-all] [NEEDINFO]
Summary: CVE-2013-2037 Python httplib2: ssl cert incorrect error handling [epel-all]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-httplib2
Version: el6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: fst_owner=mrniranjan
Depends On:
Blocks: CVE-2013-2037
TreeView+ depends on / blocked
 
Reported: 2013-05-02 06:20 UTC by Kurt Seifried
Modified: 2017-09-26 20:52 UTC (History)
5 users (show)

Fixed In Version: python-httplib2-0.9.2-0.1.el7
Doc Type: Release Note
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-26 20:52:37 UTC
mhayden: needinfo? (andreas.bierfert)


Attachments (Terms of Use)

Description Kurt Seifried 2013-05-02 06:20:44 UTC
This is an automatically created tracking bug!  It was created to ensure
that one or more security vulnerabilities are fixed in affected versions
of Fedora EPEL.

For comments that are specific to the vulnerability please use bugs filed
against the "Security Response" product referenced in the "Blocks" field.

For more information see:
http://fedoraproject.org/wiki/Security/TrackingBugs

When creating a Bodhi update request, please use the bodhi submission link
noted in the next comment(s).  This will include the bug IDs of this
tracking bug as well as the relevant top-level CVE bugs.

Please also mention the CVE IDs being fixed in the RPM changelog and the
Bodhi notes field when available.

Please note: this issue affects multiple supported versions of Fedora EPEL.
Only one tracking bug has been filed; please ensure that it is only closed
when all affected versions are fixed.

[bug automatically created by: add-tracking-bugs]

Comment 1 Kurt Seifried 2013-05-02 06:20:53 UTC
Please use the following update submission link to create the Bodhi
request for this issue as it contains the top-level parent bug(s) as well
as this tracking bug.  This will ensure that all associated bugs get
updated when new packages are pushed to stable.

Please also ensure that the "Close bugs when update is stable" option
remains checked.

Bodhi update submission link:
https://admin.fedoraproject.org/updates/new/?type_=security&bugs=958638,958642

Comment 2 Major Hayden 2015-07-12 04:50:48 UTC
Would it be possible to bring EPEL 5, 6, and 7 versions of this package in line with the Fedora versions?  0.9.1 is packaged for Fedora 21/22 and it doesn't have this vulnerability.

For what it's worth, I tested 0.9.1 on EL6/7 via pip and the module seems to work fine.

I'll be glad to help co-maintain those builds if needed.

Comment 3 Fedora Update System 2017-09-07 21:23:36 UTC
google-api-python-client-1.6.2-4.el7 python-httplib2-0.9.2-0.1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-59c79d3a8a

Comment 4 Fedora Update System 2017-09-08 21:48:24 UTC
google-api-python-client-1.6.2-4.el7, python-httplib2-0.9.2-0.1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-59c79d3a8a

Comment 5 Fedora Update System 2017-09-09 01:32:01 UTC
google-api-python-client-1.6.3-1.el7 python-httplib2-0.9.2-0.1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-59c79d3a8a

Comment 6 Fedora Update System 2017-09-10 05:19:44 UTC
google-api-python-client-1.6.3-1.el7, python-httplib2-0.9.2-0.1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-59c79d3a8a

Comment 7 Fedora Update System 2017-09-26 20:52:37 UTC
google-api-python-client-1.6.3-1.el7, python-httplib2-0.9.2-0.1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.