Bug 958690 - cannot start documents after collection testing
Summary: cannot start documents after collection testing
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-documents   
(Show other bugs)
Version: 7.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: beta
: 7.0
Assignee: Debarshi Ray
QA Contact: Desktop QE
Tomas Capek
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1297830 1313485
TreeView+ depends on / blocked
 
Reported: 2013-05-02 08:48 UTC by Vladimir Benes
Modified: 2016-11-04 06:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Flat document collections When using the *gnome-documents* application, it was possible include one collection into another and then vice versa at the same time. Consequently, the application terminated unexpectedly. This update ensures that the collections are flat and do not allow circular chains of collections, thus fixing this bug.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 06:45:36 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2458 normal SHIPPED_LIVE gnome-documents bug fix update 2016-11-03 14:05:13 UTC
GNOME Bugzilla 701087 None None None Never

Description Vladimir Benes 2013-05-02 08:48:27 UTC
Description of problem:
I played a bit with collections and I found one crash. After that I even cannot start g-d any more. see reproducer

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.have one document in g-d
2.place that document into two collections
3.right click select those two collections only
4.go into collection dialog via +
5.click several times the first and the second collection there 
  
Actual results:
crash,g-d doesn't start any more

Expected results:
normal sane behaviour

Additional info:

Comment 1 Vladimir Benes 2013-05-02 08:49:15 UTC
version:
gnome-documents-3.8.1-1

Comment 2 Debarshi Ray 2013-05-27 15:12:15 UTC
We should not allow collections to be added to or removed from themselves.

Comment 3 RHEL Product and Program Management 2014-03-22 06:52:29 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 Michael Boisvert 2015-05-19 20:48:51 UTC
I was able to reproduce (kinda) on gnome-documents-3.14.3-1.el7.x86_64. Gnome-Documents didn't crash for me, but I was able to add a collection to itself and it created an infinite loop of those collections. Similar issue except no crash. But as comment #2 says, collections probably shouldn't be able to be added or removed from themselves.

Comment 6 Debarshi Ray 2016-06-15 10:36:01 UTC
I have built gnome-documents-3.14.3-3.el7:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=11181410

This prevents nested collections and ensures that they are always flat. This is in line with what we did upstream in more recent versions.

Comment 12 errata-xmlrpc 2016-11-04 06:45:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2458.html


Note You need to log in before you can comment on or make changes to this bug.