Bug 958691 - nfs-root-squash: rename creates a file on a file residing inside a sticky bit set directory
Summary: nfs-root-squash: rename creates a file on a file residing inside a sticky bit...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: access-control
Version: mainline
Hardware: x86_64
OS: All
medium
urgent
Target Milestone: ---
Assignee: Raghavendra Bhat
QA Contact:
URL:
Whiteboard:
Depends On: 956957
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-02 08:48 UTC by Raghavendra Bhat
Modified: 2014-06-13 05:52 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 956957
Environment:
Last Closed: 2014-04-17 11:41:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2013-05-02 08:50:21 UTC
REVIEW: http://review.gluster.org/4934 (system/posix-acl: check for the sticky bit of the parent directory) posted (#1) for review on master by Raghavendra Bhat (raghavendra@redhat.com)

Comment 2 Anand Avati 2013-05-02 08:52:20 UTC
REVIEW: http://review.gluster.org/4934 (system/posix-acl: check for the sticky bit of the parent directory) posted (#2) for review on master by Raghavendra Bhat (raghavendra@redhat.com)

Comment 3 Raghavendra Bhat 2013-05-02 11:23:10 UTC
http://review.gluster.org/#/c/4934/ has been submitted for review.

Comment 4 Anand Avati 2013-06-03 23:11:44 UTC
COMMIT: http://review.gluster.org/4934 committed in master by Anand Avati (avati@redhat.com) 
------
commit 3f5e575a0744488b4a1719c3e61864c3abc9ac22
Author: Raghavendra Bhat <raghavendra@redhat.com>
Date:   Thu May 2 12:56:46 2013 +0530

    system/posix-acl: check for the sticky bit of the parent directory
    
    * While creating links, check if there is sticky bit set for the parent
      directory and whether the sticky bit permits the user to create the link.
    
    Change-Id: Ic0d09d9ed579c4eb47462c71602a3a60cc7d3bc1
    BUG: 958691
    Signed-off-by: Raghavendra Bhat <raghavendra@redhat.com>
    Reviewed-on: http://review.gluster.org/4934
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>

Comment 5 Anand Avati 2013-09-05 10:40:27 UTC
REVIEW: http://review.gluster.org/5813 (system/posix-acl: check for the sticky bit of the parent directory) posted (#1) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)

Comment 6 Anand Avati 2013-09-05 15:12:10 UTC
REVIEW: http://review.gluster.org/5813 (system/posix-acl: check for the sticky bit of the parent directory) posted (#2) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)

Comment 7 Anand Avati 2013-09-06 04:26:12 UTC
REVIEW: http://review.gluster.org/5813 (system/posix-acl: check for the sticky bit of the parent directory) posted (#3) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)

Comment 8 Anand Avati 2013-09-06 07:42:10 UTC
REVIEW: http://review.gluster.org/5813 (system/posix-acl: check for the sticky bit of the parent directory) posted (#4) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)

Comment 9 Anand Avati 2013-09-07 15:00:24 UTC
REVIEW: http://review.gluster.org/5813 (system/posix-acl: check for the sticky bit of the parent directory) posted (#5) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)

Comment 10 Anand Avati 2013-09-10 00:24:56 UTC
COMMIT: http://review.gluster.org/5813 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 975d0c003ac77a28be2847fb96a8a86251ee08b2
Author: Raghavendra Bhat <raghavendra@redhat.com>
Date:   Thu May 2 12:56:46 2013 +0530

    system/posix-acl: check for the sticky bit of the parent directory
    
    * While creating links, check if there is sticky bit set for the parent
      directory and whether the sticky bit permits the user to create the link.
    
    Change-Id: Ic0d09d9ed579c4eb47462c71602a3a60cc7d3bc1
    BUG: 958691
    Signed-off-by: Raghavendra Bhat <raghavendra@redhat.com>
    Reviewed-on: http://review.gluster.org/4934
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/5813
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 11 Niels de Vos 2014-04-17 11:41:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.