Bug 958906 - anaconda no longer writing out /etc/sysconfig/kernel
Summary: anaconda no longer writing out /etc/sysconfig/kernel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
Depends On:
Blocks: F19-accepted, F19FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-05-02 16:00 UTC by Orion Poplawski
Modified: 2013-06-12 21:45 UTC (History)
8 users (show)

Fixed In Version: anaconda-19.30.1-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-12 21:45:54 UTC


Attachments (Terms of Use)
/var/log/anaconda (242.91 KB, application/x-gzip)
2013-05-02 16:00 UTC, Orion Poplawski
no flags Details
anaconda.log (5.43 KB, text/plain)
2013-05-22 16:11 UTC, Orion Poplawski
no flags Details
anaconda.program.log (371.52 KB, text/plain)
2013-05-22 16:16 UTC, Orion Poplawski
no flags Details
anaconda.log (5.48 KB, text/plain)
2013-05-22 20:11 UTC, Orion Poplawski
no flags Details
anaconda.program.log (24.03 KB, text/plain)
2013-05-22 20:12 UTC, Orion Poplawski
no flags Details
anaconda.packaging.log (196.06 KB, text/plain)
2013-05-22 20:13 UTC, Orion Poplawski
no flags Details
anaconda.ifcfg.log (483 bytes, text/plain)
2013-05-22 20:13 UTC, Orion Poplawski
no flags Details
anaconda.storage.log (92.54 KB, text/plain)
2013-05-22 20:14 UTC, Orion Poplawski
no flags Details
syslog (98.13 KB, text/plain)
2013-05-22 20:15 UTC, Orion Poplawski
no flags Details

Description Orion Poplawski 2013-05-02 16:00:01 UTC
Created attachment 742787 [details]
/var/log/anaconda

Description of problem:

After installing F19-Alpha (and some previous versions) I no longer have an /etc/sysconfig/kernel file.  kickstart install.

Version-Release number of selected component (if applicable):
19.20-1

How reproducible:
Couple different systems.

Comment 1 Orion Poplawski 2013-05-21 16:03:09 UTC
Still the case with 19.28-1.  This prevents future kernel installs from becoming the default kernel.

Comment 2 Brian Lane 2013-05-22 00:55:52 UTC
Please attach logfiles as individual text/plain files.

Comment 3 Orion Poplawski 2013-05-22 16:11:15 UTC
Created attachment 751774 [details]
anaconda.log

Comment 4 Orion Poplawski 2013-05-22 16:16:07 UTC
Created attachment 751780 [details]
anaconda.program.log

Comment 5 Orion Poplawski 2013-05-22 16:20:36 UTC
This seems to be the relevant bit:

21:29:13,163 INFO anaconda: Installing bootloader
21:29:13,163 INFO anaconda: bootloader stage1 target device is vda
21:29:13,164 INFO anaconda: bootloader stage2 target device is vda3
21:29:13,166 DEBUG anaconda: new default image: <pyanaconda.bootloader.LinuxBootLoaderImage objec
t at 0x7feec03cd590>
21:29:13,188 ERR anaconda: failed to get package name for default kernel

Comment 6 Brian Lane 2013-05-22 19:14:05 UTC
Please try with a newer version, and include all the logs if it is still happening. Also, does the installed system boot?

Comment 7 Orion Poplawski 2013-05-22 20:11:28 UTC
Created attachment 751876 [details]
anaconda.log

Same issue with 19.29-1 from F19 Beta RC3.  I don't know how to get any newer than that.

System boots fine, but new kernels are not installed as the default, so system continues to boot the original kernel unless /etc/grub2.cfg is edited by hand.

Comment 8 Orion Poplawski 2013-05-22 20:12:00 UTC
Created attachment 751877 [details]
anaconda.program.log

Comment 9 Orion Poplawski 2013-05-22 20:13:21 UTC
Created attachment 751888 [details]
anaconda.packaging.log

Comment 10 Orion Poplawski 2013-05-22 20:13:50 UTC
Created attachment 751889 [details]
anaconda.ifcfg.log

Comment 11 Orion Poplawski 2013-05-22 20:14:20 UTC
Created attachment 751890 [details]
anaconda.storage.log

Comment 12 Orion Poplawski 2013-05-22 20:15:27 UTC
Created attachment 751891 [details]
syslog

Comment 13 Adam Williamson 2013-05-29 16:23:36 UTC
Orion: I suspect the lack of /etc/sysconfig/kernel was not actually the cause of the problem you were seeing. I suspect you tried to install a Rawhide kernel and hit https://bugzilla.redhat.com/show_bug.cgi?id=965897 . Yes? I just tried doing a 'yum update kernel' with no /etc/sysconfig/kernel , and the updated fc19 kernel was added to grub2 as the default kernel.

Comment 14 Adam Williamson 2013-05-29 16:33:48 UTC
Discussed at 2013-05-29 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-29/f19final-blocker-review-1.2013-05-29-16.02.log.txt . Rejected as a blocker as it doesn't seem to be causing the symptom claimed according to my testing, but accepted as a freeze exception issue since there's no good reason not to ship the file, so we might as well fix this, and the fix seems safe.

Comment 15 Adam Williamson 2013-05-30 02:38:07 UTC
Also fixed in 19.30.1-1, which is now in updates-testing.

Comment 16 Adam Williamson 2013-05-30 02:51:00 UTC
verified fixed in 19.31.1.

Comment 17 Adam Williamson 2013-06-12 21:45:54 UTC
We're well past 19.30.1 now, so closing.


Note You need to log in before you can comment on or make changes to this bug.