Bug 958945 - virt-manager missing a dependency on vte3
Summary: virt-manager missing a dependency on vte3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 19
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-02 18:13 UTC by Reartes Guillermo
Modified: 2013-05-28 00:30 UTC (History)
8 users (show)

Fixed In Version: virt-manager-0.10.0-0.2.gitb68faac8.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-14 04:36:16 UTC


Attachments (Terms of Use)
screen-shot of virt-manager after installing vte3 (359.39 KB, image/png)
2013-05-03 22:59 UTC, Reartes Guillermo
no flags Details
screen-shot of another (probable) missing dependecy for group virtualization (129.32 KB, image/png)
2013-05-05 17:27 UTC, Reartes Guillermo
no flags Details

Description Reartes Guillermo 2013-05-02 18:13:43 UTC
Description of problem:

F19a (updated) is installed on the Host. I connect via ssh from another system (F17) and launching virt-manager now fails. This was working previously.

I can 'connect' from F17's vir-manager, but i cannot attach iso files to guest (option not offered). So i tried via ssh and found that it no longer works.

Version-Release number of selected component (if applicable):

# uname -r 
3.9.0-301.fc19.x86_64

# yum list installed '*virt-manager*'
Loaded plugins: langpacks, refresh-packagekit
Installed Packages
virt-manager.noarch        0.10.0-0.1.gitd3f9bc8e.fc19  @updates-testing
virt-manager-common.noarch 0.10.0-0.1.gitd3f9bc8e.fc19  @updates-testing

How reproducible:
always

Steps to Reproduce:

$ ssh -Y root@stark
root@stark's password: 
Last login: Thu May  2 15:04:44 2013 from ulquiorra
# virt-manager

Current Error:

Error starting Virtual Machine Manager: cannot import name Vte

Traceback (most recent call last):
  File "/usr/share/virt-manager/virt-manager", line 301, in <module>
    main()
  File "/usr/share/virt-manager/virt-manager", line 266, in main
    from virtManager.engine import vmmEngine
  File "/usr/share/virt-manager/virtManager/engine.py", line 45, in <module>
    from virtManager.details import vmmDetails
  File "/usr/share/virt-manager/virtManager/details.py", line 38, in <module>
    from virtManager.serialcon import vmmSerialConsole
  File "/usr/share/virt-manager/virtManager/serialcon.py", line 32, in <module>
    from gi.repository import Vte
ImportError: cannot import name Vte

  
Actual results:
cannot launch virt-manager via ssh -Y

Expected results:
being able to do it (i was working previously)

Additional info:

I tried to downgrade virt-manager but failed:

# yum downgrade virt-manager
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package virt-manager.noarch 0:0.9.5-1.fc19 will be a downgrade
--> Processing Dependency: virt-manager-common = 0.9.5-1.fc19 for package: virt-manager-0.9.5-1.fc19.noarch
--> Processing Dependency: python-virtinst >= 0.600.4 for package: virt-manager-0.9.5-1.fc19.noarch
Package python-virtinst-0.600.4-1.fc19.noarch is obsoleted by virt-install-0.10.0-0.1.gitd3f9bc8e.fc19.noarch which is already installed
---> Package virt-manager.noarch 0:0.10.0-0.1.gitd3f9bc8e.fc19 will be erased
--> Finished Dependency Resolution
Error: Package: virt-manager-0.9.5-1.fc19.noarch (fedora)
           Requires: python-virtinst >= 0.600.4
           Available: python-virtinst-0.600.4-1.fc19.noarch (fedora)
               python-virtinst = 0.600.4-1.fc19
Error: Package: virt-manager-0.9.5-1.fc19.noarch (fedora)
           Requires: virt-manager-common = 0.9.5-1.fc19
           Installed: virt-manager-common-0.10.0-0.1.gitd3f9bc8e.fc19.noarch (@updates-testing)
               virt-manager-common = 0.10.0-0.1.gitd3f9bc8e.fc19
           Available: virt-manager-common-0.9.5-1.fc19.noarch (fedora)
               virt-manager-common = 0.9.5-1.fc19
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 1 Reartes Guillermo 2013-05-03 14:37:16 UTC
Update:

I tried from a local session (KDE Konsole) and it also fails with the same error.
So virt-manager does not work at all at the moment.

Currently one can either use virsh or connect via a remote virt-manager (tested with F17).

Comment 2 Reartes Guillermo 2013-05-03 14:44:15 UTC
From ~/.virt-manager/virt-manager.log:

  File "/usr/share/virt-manager/virtManager/serialcon.py", line 32, in <module>
    from gi.repository import Vte
ImportError: cannot import name Vte
[Fri, 03 May 2013 11:37:28 virt-manager 2113] INFO (cliutils:75) virt-manager startup
[Fri, 03 May 2013 11:37:28 virt-manager 2113] DEBUG (virt-manager:199) Launched as: ['/usr/share/virt-manager/virt-manager']
[Fri, 03 May 2013 11:37:28 virt-manager 2113] DEBUG (virt-manager:200) virt-manager version: 0.10.0
[Fri, 03 May 2013 11:37:28 virt-manager 2113] DEBUG (virt-manager:201) virtManager import: <module 'virtManager' from '/usr/share/virt-manager/virtManager/__init__.pyc'>
[Fri, 03 May 2013 11:37:28 virt-manager 2114] DEBUG (virt-manager:244) GTK version: 3.8.1
[Fri, 03 May 2013 11:37:28 virt-manager 2114] ERROR (importer:51) Could not find any typelib for Vte
[Fri, 03 May 2013 11:37:28 virt-manager 2114] ERROR (virt-manager:55) Error starting virt-manager
Traceback (most recent call last):
  File "/usr/share/virt-manager/virt-manager", line 301, in <module>
    main()
  File "/usr/share/virt-manager/virt-manager", line 266, in main
    from virtManager.engine import vmmEngine
  File "/usr/share/virt-manager/virtManager/engine.py", line 45, in <module>
    from virtManager.details import vmmDetails
  File "/usr/share/virt-manager/virtManager/details.py", line 38, in <module>
    from virtManager.serialcon import vmmSerialConsole
  File "/usr/share/virt-manager/virtManager/serialcon.py", line 32, in <module>
    from gi.repository import Vte
ImportError: cannot import name Vte

Comment 3 Reartes Guillermo 2013-05-03 16:05:53 UTC
Just to be sure (since i installed F19 on the early alphas), i re-installed from F19b TC2.

* Install,
* yum update
* yum groupinstall 'virtualization'
* enabled libvirtd service and rebooted.

Same error message.

Since virt-manager itself stopped working (it was working during alpha), it affects the 'recommended virtualization technology' in the 'Virtualization Requirements on:  https://fedoraproject.org/wiki/Fedora_19_Beta_Release_Criteria#Self_hosting_virtualization

The user can still use virsh or a remote (F17) virt-manager to connect to the F19 kvm host.

Comment 4 Adam Williamson 2013-05-03 22:44:34 UTC
virt-manager runs fine on my F19 desktop (though I can't attach an ISO image to a VM). I appear to have 'vte' and 'vte3' packages installed; are you missing either of those? If so, does installing one, other or both fix this? Thanks!

Comment 5 Reartes Guillermo 2013-05-03 22:59:02 UTC
Created attachment 743398 [details]
screen-shot of virt-manager after installing vte3

Humm, yes, i am missing vte3...

# yum install vte3
Loaded plugins: langpacks, refresh-packagekit
fedora/19/x86_64/metalink                                                                                |  37 kB  00:00:00     
updates/19/x86_64/metalink                                                                               | 1.8 kB  00:00:00     
updates-testing/19/x86_64/metalink                                                                       |  36 kB  00:00:00     
http://fedora.mirrors.tds.net/pub/fedora/updates/testing/19/x86_64/repodata/repomd.xml: [Errno 14] curl#6 - "Could not resolve host: fedora.mirrors.tds.net; Name or service not known"
Trying other mirror.
updates-testing                                                                                          | 4.4 kB  00:00:00     
updates-testing/19/x86_64/primary_db                                                                     | 6.4 MB  00:02:01     
updates-testing/19/x86_64/group_gz                                                                       | 373 kB  00:00:04     
Resolving Dependencies
--> Running transaction check
---> Package vte3.x86_64 0:0.34.4-1.fc19 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================
 Package                    Arch                         Version                             Repository                    Size
================================================================================================================================
Installing:
 vte3                       x86_64                       0.34.4-1.fc19                       fedora                       331 k

Transaction Summary
================================================================================================================================
Install  1 Package

Total download size: 331 k
Installed size: 966 k
Is this ok [y/N]: y
Downloading packages:
vte3-0.34.4-1.fc19.x86_64.rpm                                                                            | 331 kB  00:00:05     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : vte3-0.34.4-1.fc19.x86_64                                                                                    1/1 
  Verifying  : vte3-0.34.4-1.fc19.x86_64                                                                                    1/1 

Installed:
  vte3.x86_64 0:0.34.4-1.fc19                                                                                                   

Complete!


After installing it, virt-manager does start.

However it asks:

The following packages are not installed:
avahi-tools

I click to install it, but there is an error. (see screen-shot)


If i manually do:

# yum install avahi-tools
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package avahi-tools.x86_64 0:0.6.31-11.fc19 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================
 Package                         Arch                       Version                            Repository                  Size
================================================================================================================================
Installing:
 avahi-tools                     x86_64                     0.6.31-11.fc19                     fedora                      46 k

Transaction Summary
================================================================================================================================
Install  1 Package

Total download size: 46 k
Installed size: 81 k
Is this ok [y/N]: y
Downloading packages:
avahi-tools-0.6.31-11.fc19.x86_64.rpm                                                                    |  46 kB  00:00:02     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : avahi-tools-0.6.31-11.fc19.x86_64                                                                            1/1 
  Verifying  : avahi-tools-0.6.31-11.fc19.x86_64                                                                            1/1 

Installed:
  avahi-tools.x86_64 0:0.6.31-11.fc19                                                                                           

Complete!

After installing this, launching virt-manager works as expected.

So these packages seems to be missing: 

* vte3
* avahi-tools (which virt-manager is not able to install from gui)


I installed F19b TC2 selecting: KDE Plasma Workspaces with add-ons.

Comment 6 Adam Williamson 2013-05-03 23:02:31 UTC
Adjusting summary appropriately. I'm not sure what the deal is with installing avahi-tools via PK instead of just having a dep on it, but I'll leave that to Cole to decide what to do.

Comment 7 Adam Williamson 2013-05-03 23:03:43 UTC
I'm probably -1 blocker if the problem is just a missing dep, it's easy enough to work around.

Comment 8 Reartes Guillermo 2013-05-05 17:27:01 UTC
Created attachment 743810 [details]
screen-shot of another (probable) missing dependecy for group virtualization

I tried to use F19 virt-manager to connect to my F17 system and create a guest, to see if it also crashes on attach. Then i found the (probable) missing dependency.

When one tries to connect to another host's virt-manager via virt-mananger, it asks for openssh-askpass. I installed it manually and was able to connect.
Shoult it be part of group virtualization?

I was unable to attach an iso, because the 'browse local' button is always disabled when using a remote virt-manager. I was aware of this limitation for some time (to attach an iso i connected via ssh -Y directly and launched a local virt-manager which now fails). I was able to create a guest by importing a disk, and i saw no crash.

Comment 9 Adam Williamson 2013-05-06 17:22:27 UTC
Discussed at 2013-05-06 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-06/f19beta-blocker-review-3.2013-05-06-16.02.log.txt . As this isn't really a showstopper - it's easy enough to just 'yum install vte3' - and could easily be fixed with an update, this is rejected as a blocker; we would block more for an issue where the Beta would not work in virt unless we fixed the images themselves.

Comment 10 Cole Robinson 2013-05-09 22:26:28 UTC
Not sure what that avahi-tools thing is, nothing that virt-manager explicitly does, likely some side effect of trying to connect to avahi dbus?

Fixed the vte dep upstream, build coming soon.

Comment 11 Fedora Update System 2013-05-10 00:36:41 UTC
virt-manager-0.10.0-0.2.gitb68faac8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/virt-manager-0.10.0-0.2.gitb68faac8.fc19

Comment 12 Fedora Update System 2013-05-10 15:31:06 UTC
Package virt-manager-0.10.0-0.2.gitb68faac8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.10.0-0.2.gitb68faac8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7837/virt-manager-0.10.0-0.2.gitb68faac8.fc19
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2013-05-14 04:36:16 UTC
virt-manager-0.10.0-0.2.gitb68faac8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Adam Williamson 2013-05-28 00:30:29 UTC
this was fixed, so no need for commonbugs.


Note You need to log in before you can comment on or make changes to this bug.