Bug 958991 - mod_cluster core when use ProxyPass / balancer://bal and CreateBalancers 1
Summary: mod_cluster core when use ProxyPass / balancer://bal and CreateBalancers 1
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: mod_cluster
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: EAP 6.2.0
Assignee: Jean-frederic Clere
QA Contact: Michal Karm Babacek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-02 22:08 UTC by Michal Karm Babacek
Modified: 2013-12-15 16:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A regression found in versions 6.1.0 and 6.1.1 of JBoss EAP caused setting *CreateBalancers 1* in /conf.d/mod_cluster.conf without setting the *stickysession=JSESSIONID|jsessionid* configuration to result in a segmentation fault. This issue has been resolved in JBoss EAP 6.2. The *stickysession* element has now been added to the *CreateBalancers* configuration.
Clone Of:
Environment:
Last Closed: 2013-12-15 16:20:58 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker MODCLUSTER-334 0 Major Closed mod_cluster core when use ProxyPass / balancer://bal and CreateBalancers 1 2018-10-26 20:04:05 UTC

Description Michal Karm Babacek 2013-05-02 22:08:40 UTC
https://issues.jboss.org/browse/MODCLUSTER-334

Comment 1 Scott Mumford 2013-05-06 01:11:49 UTC
The JIRA suggests this is fixed, is that the case?

And for release notes, does the user have to add that code? And if so, where does it go?

Comment 2 Jean-frederic Clere 2013-05-06 07:08:46 UTC
I guess we need to add the patch to the next ER.
https://github.com/modcluster/mod_cluster/commit/08be77c8c393d421ca9c1abb7145fd006165df70

Comment 3 Michal Karm Babacek 2013-05-06 07:22:20 UTC
Well, yes, it is fixed in master. Target release being mod_cluster 1.2.5.Final.
It is not fixed in 1.2.4.Final though. This means this bug is present in EAP 6.1.0.ER6.

One has to add that code only if one is using "CreateBalancers 1" (mod_cluster.conf in conf.d, httpd configuration). User might want to have something like:

CreateBalancers 1
ProxyPass / balancer://qacluster

and it won't work. Workaround would be to have:

CreateBalancers 1
ProxyPass / balancer://qacluster stickysession=JSESSIONID|jsessionid

Of course, "qacluster" is an arbitrary name. Default value for ManagerBalancerName directive is "mycluster".

Comment 4 Michal Karm Babacek 2013-05-06 07:23:12 UTC
(In reply to comment #2)
> I guess we need to add the patch to the next ER.
> https://github.com/modcluster/mod_cluster/commit/
> 08be77c8c393d421ca9c1abb7145fd006165df70

Yes, if we can, it would be nice. At the moment, it is not fixed in EAP 6.1.0.ER6.

Comment 5 Permaine Cheung 2013-05-06 13:28:08 UTC
Jean-Frederic, do you have the tag 1.2.5.Final ready if we can get this in?

Comment 6 Permaine Cheung 2013-05-06 13:49:47 UTC
I asked on the AS mailing list and we're in blocker only mode, so it looks like we'll get this in EAP 6.2.0.

Jean-Frederic, please include this fix in the tag for EAP 6.2.0 and assign it to us when the new tag is ready. Thanks!

Comment 7 JBoss JIRA Server 2013-05-07 16:37:37 UTC
Michal Babacek <mbabacek> made a comment on jira MODCLUSTER-334

Verified on
[modcluster/mod_cluster/tree/1.2.x|https://github.com/modcluster/mod_cluster/tree/1.2.x].
Closing.

Comment 8 JBoss JIRA Server 2013-05-07 16:38:01 UTC
Michal Babacek <mbabacek> updated the status of jira MODCLUSTER-334 to Closed

Comment 9 Scott Mumford 2013-05-09 01:27:20 UTC
Added draft release notes text to the top of the Doc Text field above (retained original content below it). Setting NEEDINFO for technical verification of draft.

To clarify, this is a Known Issue for the 6.1 Release Notes?

Comment 10 Scott Mumford 2013-05-17 03:03:21 UTC
Removing the original info from the Doc Text field so it doesn't get picked up in auto-builds.

#######
Cause: 
   Having:
   ProxyPass / balancer://qacluster
   and CreateBalancers 1
   without any stickysession=JSESSIONID|jsessionid
   
Consequence: 
   Segmentation fault 
   [notice] child pid 7787 exit signal Segmentation fault (11)
   
Workaround (if any): 
   Add stickysession=JSESSIONID|jsessionid, so as to have:
   ProxyPass / balancer://qacluster stickysession=JSESSIONID|jsessionid


Result:

Comment 13 Michal Karm Babacek 2013-10-07 09:09:41 UTC
Verified with m_c 1.2.6, EAP 6.2.ER4 :-)

Comment 16 Scott Mumford 2013-11-20 21:16:32 UTC
Added Doc Text draft based on the 'Known Issue' text in bug 958990. 

The above draft assumes that the workaround was adopted in this release as a default.

Please comment with information if this is incorrect.

Comment 17 Jean-frederic Clere 2013-11-22 10:55:51 UTC
"In previous versions" in fact that is no correct that was regression.


Note You need to log in before you can comment on or make changes to this bug.