Bug 959195 - Dragging icon from dash to a different workspace always ends up in window opening in the current workspace instead
Summary: Dragging icon from dash to a different workspace always ends up in window ope...
Keywords:
Status: NEW
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell
Version: 7.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: beta
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
: 1099914 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-03 10:30 UTC by Vitezslav Humpa
Modified: 2019-09-18 20:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-28 14:06:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
Example screen-casting (5.24 MB, video/webm)
2013-05-09 11:45 UTC, Vitezslav Humpa
no flags Details

Description Vitezslav Humpa 2013-05-03 10:30:03 UTC
Description of problem:
Whenever trying to open an app or its new window by dragging dash icon to a different than active workspace, the window opens in current window instead.

Version-Release number of selected component (if applicable):
gnome-shell-3.8.1-2.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
I.e.
1. Be in the 'first' workspace
2. Drag any app's icon from dash to the next workspace
  
Actual results:
Window opens in the current, first workspace. If the other workspace was an empty (last) one it will move away and get restored during.

Expected results:
Window opens in the workspace we dragged the icon onto.

Comment 1 Matthias Clasen 2013-05-07 21:31:00 UTC
Which application have you tried this with ? classic mode or not ?

It works fine for me with rhythmbox

Comment 2 Vitezslav Humpa 2013-05-09 11:45:26 UTC
Created attachment 745632 [details]
Example screen-casting

Comment 3 Vitezslav Humpa 2013-05-09 11:47:47 UTC
Was happening with all apps when I was reporting. Now is a case of some apps, notably Nautilus and Firefox. Whether I am running a classic mode or not has no influence.

Comment 5 Matthias Clasen 2014-03-03 20:47:00 UTC
Still a problem. Sadly, we've run out of time to fix it for 7.0. Moving to 7.1

Comment 8 Michal Domonkos 2015-05-15 13:01:17 UTC
*** Bug 1099914 has been marked as a duplicate of this bug. ***

Comment 9 Michal Domonkos 2015-05-15 13:01:38 UTC
Still an issue in GNOME-3.14.

Comment 10 Michal Domonkos 2015-05-25 12:41:55 UTC
Not reproducible with Terminal, always reproducible with Files.

Comment 11 Michal Odehnal 2018-05-16 12:52:11 UTC
Still reproducible with gnome-shell-3.26.2-5
Firefox only, Files do not spawn New Window by dragging.

Comment 12 Vitezslav Humpa 2018-06-28 14:06:16 UTC
No longer reproducible with gnome-shell-3.28.2-1.el7.x86_64 Closing.

Comment 13 Vitezslav Humpa 2018-06-28 14:08:08 UTC
Oh, actually still reproducible with Firefox as c#11 states. Sorry, reopening.

Comment 14 Brandon Nielsen 2019-09-18 20:27:33 UTC
This appears to be an issue with much newer versions of gnome-shell as well, reproducible with Files 100% of the time on Fedora 31, gnome-shell 3.34.0-1.


Note You need to log in before you can comment on or make changes to this bug.