Bug 959448 - Report error when encountering unrecognized connection option
Summary: Report error when encountering unrecognized connection option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: python-qpid
Version: 2.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: 3.1
: ---
Assignee: Pavel Moravec
QA Contact: Michal Toth
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-03 14:00 UTC by Petr Matousek
Modified: 2015-04-14 13:46 UTC (History)
4 users (show)

Fixed In Version: python-qpid-0.30-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-14 13:46:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-5836 None None None Never
Red Hat Bugzilla 661500 None None None Never
Red Hat Product Errata RHEA-2015:0805 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.1 Release 2015-04-14 17:45:54 UTC

Internal Links: 661500

Description Petr Matousek 2013-05-03 14:00:18 UTC
Description of problem:

It would be valuable to report error when unrecognized connection option is provided to the connection object, like c++ client do. 

Currently unrecognized options are silently ignored when creating the connection, so user may for example set the mistyped connection options in the API doc (see bug 959446), and won't be aware of that something went wrong. 

Version-Release number of selected component (if applicable):
python-qpid-0.18-4

How reproducible:
100%

Steps to Reproduce:
1. pass non-supported connection option to connection object
2. no error/warning appears
  
Actual results:
unrecognized connection options are silently ignored

Expected results:
An error reported on encountering unrecognized connection option

Additional info:

Comment 1 Pavel Moravec 2014-06-26 08:46:10 UTC
Committed in upstream r1605704.

To let automated tests passing, commit r1605703 is required.

Comment 4 Michal Toth 2014-10-22 07:05:23 UTC
Python client correctly throws an exception, when incorrect connection option is passed to Connection object.

qpid.messaging.exceptions.ConnectionError: None(Unknown connection option bla with value asda)

Verified on 
python-qpid-0.30-2.el6

Comment 5 Jared MORGAN 2015-01-19 02:38:46 UTC
(In reply to Petr Matousek from comment #0)
> Description of problem:
> 
> It would be valuable to report error when unrecognized connection option is
> provided to the connection object, like c++ client do. 
> 
> Currently unrecognized options are silently ignored when creating the
> connection, so user may for example set the mistyped connection options in
> the API doc (see bug 959446), and won't be aware of that something went
> wrong. 
> 
> Version-Release number of selected component (if applicable):
> python-qpid-0.18-4
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. pass non-supported connection option to connection object
> 2. no error/warning appears
>   
> Actual results:
> unrecognized connection options are silently ignored
> 
> Expected results:
> An error reported on encountering unrecognized connection option
> 
> Additional info:

Noted that the API doc was fixed a while back. Nothing for a customer to configure here, so no Release Note required.

Comment 7 errata-xmlrpc 2015-04-14 13:46:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0805.html


Note You need to log in before you can comment on or make changes to this bug.