Bug 959534 - regression: insch() cannot add characters with attributes
regression: insch() cannot add characters with attributes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ncurses (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-03 13:42 EDT by Ian Collier
Modified: 2013-05-28 20:56 EDT (History)
2 users (show)

See Also:
Fixed In Version: ncurses-5.9-11.20130511.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-25 08:10:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test case (446 bytes, text/plain)
2013-05-03 13:42 EDT, Ian Collier
no flags Details

  None (edit)
Description Ian Collier 2013-05-03 13:42:10 EDT
Created attachment 743309 [details]
Test case

Since updating ncurses to 5.9-10.20130413, some terminal-based editors no longer work correctly.  This applies to both F17 and F18.  Version 5.9-7.20121017 definitely worked.

A testcase is attached.  It should insert the word "hello" before the word "world", pausing for a key-press after each letter.  However, it just succeeds in moving the cursor without displaying the inserted letters.  It was tried in both an xterm and a gnome-terminal, each with TERM=xterm.

Removing the COLOR_PAIR attribute from the character to be inserted makes the program work.  (The colours themselves are largely irrelevant; it seems to be the presence of the attribute in the argument to insch() that triggers the bug.)
Comment 1 Miroslav Lichvar 2013-05-06 06:11:41 EDT
CCing upstream maintainer.
Comment 2 Thomas E. Dickey 2013-05-07 05:47:30 EDT
thanks - I can see some breakage (will investigate).
Comment 3 Thomas E. Dickey 2013-05-11 14:33:58 EDT
The cause was the fix noted here: http://invisible-island.net/ncurses/NEWS-contents.html#t20121215
Essentially, Coverity pointed out that the comparison I was making was
always true due to a macro.  I removed the macro without noticing the
reason I'd used it originally.  I'm reworking that part of the code,
and the fix will be in today's patch.
Comment 4 Fedora Update System 2013-05-13 05:47:34 EDT
ncurses-5.9-11.20130511.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ncurses-5.9-11.20130511.fc17
Comment 5 Fedora Update System 2013-05-13 05:47:37 EDT
ncurses-5.9-11.20130511.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ncurses-5.9-11.20130511.fc19
Comment 6 Fedora Update System 2013-05-13 05:49:56 EDT
ncurses-5.9-11.20130511.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ncurses-5.9-11.20130511.fc18
Comment 7 Miroslav Lichvar 2013-05-13 05:50:56 EDT
Thanks for the quick fix, Thomas.

I've created updates for F17, F18, F19.
Comment 8 Thomas E. Dickey 2013-05-13 05:53:28 EDT
no problem (report bugs)
Comment 9 Fedora Update System 2013-05-13 21:27:30 EDT
Package ncurses-5.9-11.20130511.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ncurses-5.9-11.20130511.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8086/ncurses-5.9-11.20130511.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-05-25 08:10:59 EDT
ncurses-5.9-11.20130511.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-05-25 23:39:13 EDT
ncurses-5.9-11.20130511.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-05-28 20:56:33 EDT
ncurses-5.9-11.20130511.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.