Bug 9596 - incompatibility with abiword 0.7.8
incompatibility with abiword 0.7.8
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: aboot (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
http://www.abisource.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-19 18:47 EST by Cube
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-21 16:30:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cube 2000-02-19 18:47:52 EST
When abiword installed from RPM is run, segfault occurs.
When abiword installed from static tarball is run, window appears, but all
pull down menus are empty.
Bug does not appear in Redhat 6.1
Comment 1 Jeremy Katz 2000-02-20 00:21:59 EST
Here's a gdb backtrace
0x80a19b3 in signedHiWord ()
(gdb) bt
#0  0x80a19b3 in signedHiWord ()
#1  0x40035ce8 in png_read_data () from /usr/lib/libpng.so.2
#2  0x400343fe in png_read_info () from /usr/lib/libpng.so.2
#3  0x80a1a48 in UT_PNG_getDimensions ()
#4  0x808a7c6 in AP_UnixApp::_showSplash ()
#5  0x808aaba in AP_UnixApp::main ()
#6  0x808990b in main ()

Also, cross-reference to http://katz.linuxpower.org/piglet-archive/msg00059.html
(and following in the thread).  Abiword seems to be the only thing hit by this.
There's also a similar bug in Abiword's bugzilla,
http://www.abisource.com/bugzilla/show_bug.cgi?id=467

Quick and dirty work-around, run with -nosplash
Comment 2 Cristian Gafton 2000-02-21 16:30:59 EST
Most likely it is abiword that is incompatible with something in out beta.

We'll try to follow up with abiword folks, but for now I presume this is not a
bug of ours.

Note You need to log in before you can comment on or make changes to this bug.