Bug 9596 - incompatibility with abiword 0.7.8
Summary: incompatibility with abiword 0.7.8
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: aboot (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL: http://www.abisource.com
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-19 23:47 UTC by Cube
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-21 21:30:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Cube 2000-02-19 23:47:52 UTC
When abiword installed from RPM is run, segfault occurs.
When abiword installed from static tarball is run, window appears, but all
pull down menus are empty.
Bug does not appear in Redhat 6.1

Comment 1 Jeremy Katz 2000-02-20 05:21:59 UTC
Here's a gdb backtrace
0x80a19b3 in signedHiWord ()
(gdb) bt
#0  0x80a19b3 in signedHiWord ()
#1  0x40035ce8 in png_read_data () from /usr/lib/libpng.so.2
#2  0x400343fe in png_read_info () from /usr/lib/libpng.so.2
#3  0x80a1a48 in UT_PNG_getDimensions ()
#4  0x808a7c6 in AP_UnixApp::_showSplash ()
#5  0x808aaba in AP_UnixApp::main ()
#6  0x808990b in main ()

Also, cross-reference to http://katz.linuxpower.org/piglet-archive/msg00059.html
(and following in the thread).  Abiword seems to be the only thing hit by this.
There's also a similar bug in Abiword's bugzilla,
http://www.abisource.com/bugzilla/show_bug.cgi?id=467

Quick and dirty work-around, run with -nosplash

Comment 2 Cristian Gafton 2000-02-21 21:30:59 UTC
Most likely it is abiword that is incompatible with something in out beta.

We'll try to follow up with abiword folks, but for now I presume this is not a
bug of ours.


Note You need to log in before you can comment on or make changes to this bug.