Bug 959619 - libbonobo fails to update to 2.32.1-5.fc19
Summary: libbonobo fails to update to 2.32.1-5.fc19
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libbonobo
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 959620 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-04 08:22 UTC by Vadim Raskhozhev
Modified: 2013-05-23 17:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-23 17:54:56 UTC


Attachments (Terms of Use)

Description Vadim Raskhozhev 2013-05-04 08:22:41 UTC
Description of problem:
libbonobo 2.32.1-5.fc19 does not provide bonobo-activation. This leads to impossibility to update libbonobo to 2.32.1-5.fc19: yum tries to find what provides bonobo-activation, finds libbonobo-2.32.1-3.fc18.i686 and fails with "Protected multilib versions: libbonobo-2.32.1-3.fc18.i686 != libbonobo-2.32.1-5.fc19.x86_64"

Version-Release number of selected component (if applicable):
libbonobo 2.32.1-5.fc19

How reproducible:
Always

Steps to Reproduce:
1. yum update libbonobo
This will fail on F-19 with something dependant on gnome-python2-bonobo (e. g. deluge-gtk, gajim and so forth) which in turn requires bonobo-activation

  
Actual results:
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem.

Expected results:
Successful update to libbonobo 2.32.1-5.fc19

Additional info: the error may vary on 32 bit systems

Comment 1 Vadim Raskhozhev 2013-05-04 08:40:13 UTC
*** Bug 959620 has been marked as a duplicate of this bug. ***

Comment 2 Gwyn Ciesla 2013-05-06 12:55:28 UTC
Can you post the complete yum output?  The bonobo-activation change looks like it took place about 10 years ago, and manual requires should have been changed to libbonobo or dropped and replaced by automatic requires in that time.

Comment 3 Vadim Raskhozhev 2013-05-06 13:25:46 UTC
(In reply to comment #2)
There is http://koji.fedoraproject.org/koji/buildinfo?buildID=416064 already in updates-testing which fixes exactly this issue:

- Drop requires on bonobo-activation, since it is the same as libbonobo, but that package dropped the provides.

Updating both libbonobo and gnome-python2-bonobo to 2.32.1-5.fc19 and 2.28.1-12.fc19 works OK now, so as for me, this bug shall be closed FIXED. Sorry for disturbing.

Comment 4 Vadim Raskhozhev 2013-05-23 17:54:56 UTC
Unsure whether I have the right to close this bug but since I've opened it and it seems fixed I think it should be closed.


Note You need to log in before you can comment on or make changes to this bug.