Bug 959677 - IndexError: list index out of range
Summary: IndexError: list index out of range
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:92d2f9b2f593669103b05262dcc...
Depends On:
Blocks: F19Blocker, F19FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2013-05-04 17:42 UTC by Cybertimber2011
Modified: 2013-06-12 03:39 UTC (History)
20 users (show)

Fixed In Version: anaconda-19.30.3-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-12 03:39:36 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (461.28 KB, text/plain)
2013-05-04 17:43 UTC, Cybertimber2011
no flags Details
File: anaconda.log (24.56 KB, text/plain)
2013-05-04 17:43 UTC, Cybertimber2011
no flags Details
File: backtrace (757 bytes, text/plain)
2013-05-04 17:43 UTC, Cybertimber2011
no flags Details
File: environ (845 bytes, text/plain)
2013-05-04 17:43 UTC, Cybertimber2011
no flags Details
File: ifcfg.log (490 bytes, text/plain)
2013-05-04 17:43 UTC, Cybertimber2011
no flags Details
File: lsblk_output (2.67 KB, text/plain)
2013-05-04 17:43 UTC, Cybertimber2011
no flags Details
File: messages (188.06 KB, text/plain)
2013-05-04 17:43 UTC, Cybertimber2011
no flags Details
File: nmcli_dev_list (3.59 KB, text/plain)
2013-05-04 17:43 UTC, Cybertimber2011
no flags Details
Anaconda Traceback (jskladan) (981.65 KB, text/plain)
2013-05-23 09:08 UTC, Josef Skladanka
no flags Details

Description Cybertimber2011 2013-05-04 17:42:57 UTC
Description of problem:
Popped up when I clicked Storage > installation disks
Fedora-Live-Desktop-i686-19-Beta-TC3-1.iso created using Liveusb creator 3.11.8. Trying to install on Dell Optiplex GX620.
The following was filed automatically by anaconda:
anaconda 19.24-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 286, in execute
    self.bootDrive = disk_names[0]
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1564, in doKickstartStorage
    ksdata.bootloader.execute(storage, ksdata, instClass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 392, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
IndexError: list index out of range

Version-Release number of selected component:
anaconda-19.24-1.fc19.i686

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=LIVE rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-301.fc19.i686
other involved packages: python-libs-2.7.4-3.fc19.i686
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
ureports_counter: 1
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 392, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1564, in doKickstartStorage
    ksdata.bootloader.execute(storage, ksdata, instClass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 286, in execute
    self.bootDrive = disk_names[0]
IndexError: list index out of range

Potential duplicate: bug 890881

Comment 1 Cybertimber2011 2013-05-04 17:43:03 UTC
Created attachment 743556 [details]
File: anaconda-tb

Comment 2 Cybertimber2011 2013-05-04 17:43:06 UTC
Created attachment 743557 [details]
File: anaconda.log

Comment 3 Cybertimber2011 2013-05-04 17:43:07 UTC
Created attachment 743558 [details]
File: backtrace

Comment 4 Cybertimber2011 2013-05-04 17:43:09 UTC
Created attachment 743559 [details]
File: environ

Comment 5 Cybertimber2011 2013-05-04 17:43:11 UTC
Created attachment 743560 [details]
File: ifcfg.log

Comment 6 Cybertimber2011 2013-05-04 17:43:13 UTC
Created attachment 743561 [details]
File: lsblk_output

Comment 7 Cybertimber2011 2013-05-04 17:43:15 UTC
Created attachment 743562 [details]
File: messages

Comment 8 Cybertimber2011 2013-05-04 17:43:17 UTC
Created attachment 743563 [details]
File: nmcli_dev_list

Comment 9 Cybertimber2011 2013-05-04 17:53:19 UTC
Correction in my steps to reproduce:
I click on Installation Destination,
Select the disk,
Click Done.
After a few seconds, the unknown error has occured message pops up.

What should happen is when you click done, Usually it would pop up "Installation Options" and allow me to choose custom paritioning.
Oddly it does allow this on a second launch of "Install to Hard Drive".

Comment 10 Matthew Javelet 2013-05-06 04:27:01 UTC
Description of problem:
What I did was select the hard drive I wanted to modify, I then hit done and this error occured.

Version-Release number of selected component:
anaconda-19.24-1.fc19.x86_64

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:UUID=C2D3-9AD9 rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-301.fc19.x86_64
other involved packages: python-libs-2.7.4-3.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
ureports_counter: 1
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 392, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1564, in doKickstartStorage
    ksdata.bootloader.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 286, in execute
    self.bootDrive = disk_names[0]
IndexError: list index out of range

Comment 11 Clemens Eisserer 2013-05-16 12:26:21 UTC
Description of problem:
clicked the done button after manually editing the partition scheme

Version-Release number of selected component:
anaconda-19.27-1.fc19.i686

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=/ubninit root=UUID=0680-B55F rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 BOOT_IMAGE=/ubnkern 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.1-301.fc19.i686
other involved packages: python-libs-2.7.4-4.fc19.i686
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 390, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1641, in doKickstartStorage
    ksdata.bootloader.execute(storage, ksdata, instClass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 287, in execute
    self.bootDrive = disk_names[0]
IndexError: list index out of range

Comment 12 Josef Skladanka 2013-05-23 08:57:50 UTC
Description of problem:
Went into Disk selection spoke, unselected disk, clicked Done, went into the Disk selection spoke again, selected disk, reclaimed all space.

Version-Release number of selected component:
anaconda-19.30-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   BOOT_IMAGE=/syslinux/vmlinuz0 root=live:UUID=61CF-12BE ro rd.live.image quiet rhgb
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
other involved packages: python-libs-2.7.4-4.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 390, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1641, in doKickstartStorage
    ksdata.bootloader.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 287, in execute
    self.bootDrive = disk_names[0]
IndexError: list index out of range

Comment 13 Josef Skladanka 2013-05-23 09:07:15 UTC
Reproducer for Beta RC4:
1) Go to Storage Spoke
2) De-select all disks
3) Click Done

Reproducible all times, checked on multiple computers (Mac and PC)

Proposing as Beta Blocker per http://fedoraproject.org/wiki/Fedora_19_Beta_Release_Criteria#Guided_partitioning

Comment 14 Josef Skladanka 2013-05-23 09:08:38 UTC
Created attachment 752051 [details]
Anaconda Traceback (jskladan)

Complete traceback for the error

Comment 15 Adam Williamson 2013-05-23 10:11:04 UTC
This kinda sucks, but my initial inclination is -1 blocker on the basis it's pretty easy to work around and you probably haven't done too much configuration if you hit this one (so rebooting isn't a huge PITA).

I'm not a huge fan of the "reject invalid operations" criterion to be honest, but I've never been able to come up with a better way of wording it - there are some cases like this where it makes sense for them to be blockers...

Comment 16 Josef Skladanka 2013-05-23 10:34:31 UTC
The reason for proposing this as a Blocker is not the "reject invalid operations" in the first place. It is "just" a criterion to please those "if it does not break some criterion, it is not a blocker" voices ;)

The thing is, that the "check mark" on the selected HDD in the Storage spoke is quite dark and indistinctive, that I actually missed the fact that the disk is already selected, so I clicked on the HDD "to select it" pushed done and got an error. And I can imagine that I'd do it again ("selecting, but de-selecting in fact") after the reboot, before I noticed that the disk already is selected.

Comment 17 Adam Williamson 2013-05-23 10:39:58 UTC
Yeah, I suspect that's what happened to the other reporters. Someone else was complaining to me about it yesterday. I don't know what the rationale was for switching from 'highlight indicates selected' to 'check mark indicates selected', but it doesn't seem to be perfect.

I'm still probably -1 on balance, though.

Comment 18 Jaroslav Reznik 2013-05-23 10:58:04 UTC
And it's possible to document it, to avoid hitting the same problem again (that selecting but deselecting in fact). It's still crasher but not a very significant one, I'm too more -1 blocker on this one.

Comment 19 Vratislav Podzimek 2013-05-23 12:19:23 UTC
From what I've found out the 'storage.disks' lists only the (protected) USB device and thus the traceback. For some reason the SATA disk is missing in storage.disks. David, any idea?

Comment 20 Kamil Páral 2013-05-23 12:27:23 UTC
We have tested several configurations. It seems to be related to a process of USB conversion with livecd-iso-to-disk. If you try that approach in VM, or on bare metal with CD, it doesn't crash. It crashes only with a USB media converted using l-i-t-d (and maybe liveusb-creator, not tested). dd approach is fine (because anaconda shows the disks differently in this case).

Comment 21 Clemens Eisserer 2013-05-23 13:50:59 UTC
Happend for me twice with an unetbootin generated usb-stick.

Comment 22 Adam Williamson 2013-05-23 14:38:16 UTC
clemens: does such a stick show up on the disk selection screen or not? If it does, it's basically the same case as litd.

Comment 23 Kamil Páral 2013-05-23 15:31:02 UTC
Adam: litd created sticks don't show up graphically on the disk selection screen. dd created sticks do.

I'd vote -1 blocker here, because 1) it affects only usb sticks created in a specific way (litd, maybe liveusb-creator, not dd) 2) it requires an action that not everyone performs 3) there is no data loss.

Comment 24 Adam Williamson 2013-05-23 15:34:54 UTC
kamil: yeah, I reversed those inadvertently.

Comment 25 Jóhann B. Guðmundsson 2013-05-23 15:37:52 UTC
-1 blocker since usb creation works with dd ( either or condition ) but I think we should have this fixed for final

Comment 26 Adam Williamson 2013-05-23 17:12:02 UTC
Discussed at 2013-05-23 Fedora 19 Beta Go/No-Go meeting, acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting-2/2013-05-23/f19_beta_gono-go_meeting.2013-05-23-17.01.log.txt . Rejected as a blocker: as discussed above, this is kind of icky, but it only affects a fairly specific scenario (a certain type of install media AND a certain type of unnecessary action taken by mistake) and doesn't have any catastrophic consequences, so it doesn't seem to have a broad enough impact to qualify as breaking the criteria and hence blocking release. We will document it.

Comment 27 David Lehman 2013-05-24 01:55:38 UTC
It looks like the only selected disk also contains the live media. Would it be suitable in these cases to install the bootloader to the MBR of the lone selected disk?

Comment 28 Adam Williamson 2013-05-24 04:08:29 UTC
Isn't the problem that it's considering the disk with the live media to be 'selected' at all? It never should be. It is supposed to be completely filtered out of any consideration at all as an install target device.

Comment 29 Clemens Eisserer 2013-05-24 06:52:46 UTC
Adam: Exactly my thoughts. It simply doesn't make any sence to propt the live media for installation.

Comment 30 Kamil Páral 2013-05-24 08:35:49 UTC
(In reply to David Lehman from comment #27)
> It looks like the only selected disk also contains the live media. Would it
> be suitable in these cases to install the bootloader to the MBR of the lone
> selected disk?

If that's what the logs say, then this might be the source of the problem, anaconda detects it incorrectly. As per comment 12, the Live media is _not_ visible in the selection dialog (thus should not be selected) and the only visible local drive was _unselected_ (thus should not be selected).

Comment 31 Andreas Tunek 2013-05-25 10:21:03 UTC
Description of problem:
Clicked ok on the installtion destination

Version-Release number of selected component:
anaconda-19.30-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   BOOT_IMAGE=/syslinux/vmlinuz0 root=live:UUID=1CFD-FF90 rw rd.live.image overlay=UUID=1CFD-FF90 quiet rhgb
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
other involved packages: python-libs-2.7.4-4.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 390, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1641, in doKickstartStorage
    ksdata.bootloader.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 287, in execute
    self.bootDrive = disk_names[0]
IndexError: list index out of range

Comment 32 Vratislav Podzimek 2013-05-27 10:35:53 UTC
Patch sent to anaconda-patches.

Comment 33 Vratislav Podzimek 2013-05-27 10:39:33 UTC
Kamile, could you guys please test the following updates image?
http://vpodzime.fedorapeople.org/959677_updates.img

Comment 34 Kamil Páral 2013-05-27 12:05:56 UTC
(In reply to Vratislav Podzimek from comment #33)
Works. No longer reproducible.

Comment 35 Vratislav Podzimek 2013-05-27 12:11:15 UTC
(In reply to Kamil Páral from comment #34)
> (In reply to Vratislav Podzimek from comment #33)
> Works. No longer reproducible.
Nice! If anybody wants a patch for this to be included in the final release, please propose this as a final blocker.

Comment 36 Adam Williamson 2013-05-27 19:11:51 UTC
Please, that's not the right way to do it. The blocker list is a list of bugs that must be fixed before we can release, not a todo list or freeze exception list. If you really want to apply a freeze to anaconda for the entire post-Beta period then we can use the freeze exception process, but really, that applies to the official Fedora freeze, which does not kick in until 2013-06-18; if anaconda wants to apply a different freeze policy it would make sense for anaconda team to track your own freeze exceptions for your private freeze.

Comment 37 Vratislav Podzimek 2013-05-28 08:24:04 UTC
(In reply to Adam Williamson from comment #36)
> Please, that's not the right way to do it. The blocker list is a list of
> bugs that must be fixed before we can release, not a todo list or freeze
> exception list. If you really want to apply a freeze to anaconda for the
> entire post-Beta period then we can use the freeze exception process, but
> really, that applies to the official Fedora freeze, which does not kick in
> until 2013-06-18; if anaconda wants to apply a different freeze policy it
> would make sense for anaconda team to track your own freeze exceptions for
> your private freeze.
Okay, good to know.

Comment 38 Adam Williamson 2013-05-28 17:33:48 UTC
vpodzime: so I chatted to bcl and he does want to have outside input on what to put in anaconda throughout the 'final' phase, so what you can tell people is 'if you want to see this in Final, nominate it as a freeze exception', and we will review FEs for anaconda throughout this post-beta time. But the blocker list is always reserved for tracking actual release blocking issues, not for any other purpose.

Comment 39 Adam Williamson 2013-05-28 23:49:24 UTC
I'm not un-nominating this as a blocker because, as it happens, it's actually a reasonable candidate for blocker status.

Comment 40 Ellie 2013-05-29 13:46:04 UTC
Description of problem:
I did my disk setup, then I entered the passphrase for the LUKS encryption as asked, and when I had the password entered twice and confirmed, this error happened.

Version-Release number of selected component:
anaconda-19.30-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:UUID=EF7A-8437 rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
other involved packages: python-libs-2.7.4-4.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 390, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1641, in doKickstartStorage
    ksdata.bootloader.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 287, in execute
    self.bootDrive = disk_names[0]
IndexError: list index out of range

Comment 41 Ellie 2013-05-29 14:02:25 UTC
Description of problem:
I went into the hard disk install location screen, picked the only available hard disk and clicked on "Done".

Version-Release number of selected component:
anaconda-19.30-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:UUID=EF7A-8437 rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
other involved packages: python-libs-2.7.4-4.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 390, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1641, in doKickstartStorage
    ksdata.bootloader.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 287, in execute
    self.bootDrive = disk_names[0]
IndexError: list index out of range

Comment 42 Adam Williamson 2013-05-29 17:58:06 UTC
Discussed at 2013-05-29 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-29/f19final-blocker-review-1.2013-05-29-16.02.log.txt . Accepted as a blocker per Beta criteria "When using the guided/custom partitioning flow, the installer must be able to ... reject or disallow invalid disk and volume configurations without crashing."

https://fedoraproject.org/wiki/Fedora_19_Beta_Release_Criteria#Guided_partitioning
https://fedoraproject.org/wiki/Fedora_19_Beta_Release_Criteria#Custom_partitioning

Comment 43 Fedora Update System 2013-05-30 02:08:38 UTC
anaconda-19.30.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.30.1-1.fc19

Comment 44 Fedora Update System 2013-05-30 17:54:12 UTC
Package anaconda-19.30.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.30.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9668/anaconda-19.30.1-1.fc19
then log in and leave karma (feedback).

Comment 45 satellitgo 2013-06-01 07:28:09 UTC
http://alt.fedoraproject.org/pub/alt/anaconda/anaconda-19.30.1-boot.iso

Fixed
 https://bugzilla.redhat.com/show_bug.cgi?id=959677
Installed 2 times

Default gnome install to VirtualBox worked as expected,
- 1024 Memory, 8 GB VBox HD
- root and user setup in anaconda 19.30.1-1.
   (note called 19.30.1-boot.iso on alt.fedoraproject directory, but is 19.30.1-1 as displayed when started.)
- Yellow warning triangles are back in Main Hub
- VirtualBox Disk Selection is uncoloured with already present check mark when first entering spoke.
- 1228 files installed
reboot: 
 4m[terminated]
 2 minute wait then shuts down
Reboots to USER  and Password
 G-I-S Welcome then goes to  Start using GNOME3 Video
 GNOME 3.8.2

Default install 2 with same VirtualBox HD
 Main hub to Installation Destination: Clicked on HD it colored to blue and check mark goes away. [Done]]

Installation Destination: No disks selected yellow triangle
Installation Destination (2nd entry) Disk is Colored and has check mark on disk [Done]
[Installation options pop up] set partition to Standard Partition [Reclaim space]
 delete [reclaim space] 
[Begin Installation]
Main Hub [begin installation]

Test Cases Passed: 
https://fedoraproject.org/wiki/QA:Testcase%20Anaconda%20User%20Interface%20Graphical

https://fedoraproject.org/wiki/QA:Testcase%20Anaconda%20autopart%20install

https://fedoraproject.org/wiki/QA:Testcase%20Anaconda%20autopart%20(reclaim)%20install

Comment 46 satellitgo 2013-06-01 10:19:03 UTC
(In reply to satellit from comment #45)
> http://alt.fedoraproject.org/pub/alt/anaconda/anaconda-19.30.1-boot.iso
> 
> Fixed
>  https://bugzilla.redhat.com/show_bug.cgi?id=959677
> Installed 2 times
> 
> Default gnome install to VirtualBox worked as expected,
> - 1024 Memory, 8 GB VBox HD
> - root and user setup in anaconda 19.30.1-1.
>    (note called 19.30.1-boot.iso on alt.fedoraproject directory, but is
> 19.30.1-1 as displayed when started.)
> - Yellow warning triangles are back in Main Hub
> - VirtualBox Disk Selection is uncoloured with already present check mark
> when first entering spoke.
> - 1228 files installed
> reboot: 
>  4m[terminated]
>  2 minute wait then shuts down
> Reboots to USER  and Password
>  G-I-S Welcome then goes to  Start using GNOME3 Video
>  GNOME 3.8.2
> 
> Default install 2 with same VirtualBox HD
>  Main hub to Installation Destination: Clicked on HD it colored to blue and
> check mark goes away. [Done]]
> 
> Installation Destination: No disks selected yellow triangle
> Installation Destination (2nd entry) Disk is Colored and has check mark on
> disk [Done]
> [Installation options pop up] set partition to Standard Partition [Reclaim
> space]
>  delete [reclaim space] 
> [Begin Installation]
> Main Hub [begin installation]
> 
> Test Cases Passed: 
> https://fedoraproject.org/wiki/QA:
> Testcase%20Anaconda%20User%20Interface%20Graphical
> 
> https://fedoraproject.org/wiki/QA:Testcase%20Anaconda%20autopart%20install
> 
> https://fedoraproject.org/wiki/QA:
> Testcase%20Anaconda%20autopart%20(reclaim)%20install

Added install 2 works

I added my google mail account in G-I-S;It appears in evolution mail and works
I can send and receive e-mail

Comment 47 Fedora Update System 2013-06-03 22:19:23 UTC
anaconda-19.30.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.30.2-1.fc19

Comment 48 Fedora Update System 2013-06-06 18:38:14 UTC
anaconda-19.30.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.30.3-1.fc19

Comment 49 Kamil Páral 2013-06-07 11:44:29 UTC
Josef Skladanka verified that this is fixed.

Comment 50 Fedora Update System 2013-06-12 03:39:36 UTC
anaconda-19.30.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.