Bug 959688 - unrecoverable error when switching from BTRFS to LVM in manual partitioning
Summary: unrecoverable error when switching from BTRFS to LVM in manual partitioning
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-04 20:20 UTC by Chris Murphy
Modified: 2013-05-28 00:31 UTC (History)
8 users (show)

Fixed In Version: pykickstart-1.99.31-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-18 04:55:34 UTC


Attachments (Terms of Use)
anaconda.log (15.29 KB, text/plain)
2013-05-04 20:23 UTC, Chris Murphy
no flags Details
program.log (17.40 KB, text/plain)
2013-05-04 20:23 UTC, Chris Murphy
no flags Details
storage.log (143.86 KB, text/plain)
2013-05-04 20:24 UTC, Chris Murphy
no flags Details
storage.state (20.00 KB, text/plain)
2013-05-04 20:24 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2013-05-04 20:20:23 UTC
Description of problem:
In Manual Partitioning, changing a mount point set to BTRFS device type to LVM causes the mount point to vanish, and an error banner to appear: unrecoverable error.


Version-Release number of selected component (if applicable):
anaconda 19.24-1


How reproducible:
Always.


Steps to Reproduce:
1. Installation options, choose "review/modify my disk partitions" and change partition scheme to BTRFS.
2. In manual partitioning, create a new root mount point/partition of any size.
3. Change the device type of the mount point to LVM.
  
Actual results:
Mount point vanishes. Unrecoverable error banner appears.

Expected results:
For the device type to be successfully changed to LVM.

Additional info:

Comment 1 Chris Murphy 2013-05-04 20:23:35 UTC
Created attachment 743580 [details]
anaconda.log

Comment 2 Chris Murphy 2013-05-04 20:23:47 UTC
Created attachment 743583 [details]
program.log

Comment 3 Chris Murphy 2013-05-04 20:24:01 UTC
Created attachment 743584 [details]
storage.log

Comment 4 Chris Murphy 2013-05-04 20:24:13 UTC
Created attachment 743585 [details]
storage.state

Comment 5 Chris Murphy 2013-05-04 20:29:20 UTC
Proposing as beta blocker.
"When using the custom partitioning flow, the installer must be able to: Create mount points backed by ext4 partitions, LVM volumes or btrfs volumes, or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions"

Comment 6 Adam Williamson 2013-05-06 16:30:26 UTC
Discussed at 2013-05-06 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-06/f19beta-blocker-review-3.2013-05-06-16.02.log.txt . It doesn't seem to be clear from the report whether this bug is a showstopper or just an inconvenience. Chris, can you clarify the exact impact of this bug when you hit it? Does it prevent you going any further, or can you move on by e.g. removing and re-creating the mount point? We will decide on the status of this bug once we have more information.

Comment 7 Chris Murphy 2013-05-06 16:58:46 UTC
Short version: Prevents me from going further, I must quit and relaunch the installer (live), or reboot (dvd/netinst).

Long version: Once user makes a partition scheme selection in Installation Options, it's apparently not possible in the present anaconda (unlike 18.x) to get back to Installation. Since I chose BTRFS in Installation Options, that's the default device type for all created mount points (except /boot). When I create a new mount point, it starts out as Btrfs, I change it to LVM, click Apply, and the mount point vanishes with the unrecoverable error described. So it's inconvenient, with a likely non-obvious work around: relaunch/reboot to the installer, and do NOT pick BTRFS in Installation Options as the partition scheme.

Comment 8 Adam Williamson 2013-05-07 22:47:31 UTC
So I played around with this a bit.

If I set BTRFS on Installation Options, go to custom part, create partitions with the helper link, and then change the / partition from BTRFS to LVM, I get an orange error bar "Device reconfiguration failed. Click for details." If I click on it, I see a dialog which says "invalid raid level descriptor single" and just has a Close button. If I click Close, the partition reverts to BTRFS (and its size shrinks to 1GB, for some reason).

However, I can change it from BTRFS to Standard Partition and then to LVM, and that works.

I also note that if I set the dropdown on Installation Options to LVM, go into custom part, and create partitions, I can then flip those partitions between LVM and BTRFS indefinitely with no apparent ill effects.

So this bug only affects the case where you set the dropdown to BTRFS before going into custom partitioning, and only manifests when you try to change a partition directly from BTRFS to LVM in that case; if you go via Standard Partition as an intermediary, it works okay.

Comment 9 Adam Williamson 2013-05-08 16:39:15 UTC
Discussed at 2013-05-08 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-08/f19beta-blocker-review-4.2013-05-08-16.00.log.txt . Rejected as a blocker: clearly a bug, and annoying if you hit the precise path that causes it, but it's quite a specific path (so unlikely to be hit that often) and it is relatively easily workaroundable.

Comment 10 David Lehman 2013-05-14 15:36:21 UTC
This occurs when switching from btrfs with raid level "single" to lvm.

Comment 11 Fedora Update System 2013-05-15 22:25:42 UTC
anaconda-19.27-1.fc19, pykickstart-1.99.31-1.fc19, python-blivet-0.14-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.27-1.fc19

Comment 12 Fedora Update System 2013-05-16 05:22:08 UTC
Package anaconda-19.27-1.fc19, pykickstart-1.99.31-1.fc19, python-blivet-0.14-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.27-1.fc19 pykickstart-1.99.31-1.fc19 python-blivet-0.14-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8322/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.27-1.fc19
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2013-05-17 22:19:37 UTC
Package pykickstart-1.99.31-1.fc19, anaconda-19.28-1.fc19, python-blivet-0.14-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.31-1.fc19 anaconda-19.28-1.fc19 python-blivet-0.14-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8322/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.28-1.fc19
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2013-05-18 04:55:34 UTC
pykickstart-1.99.31-1.fc19, anaconda-19.28-1.fc19, python-blivet-0.14-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Adam Williamson 2013-05-28 00:31:01 UTC
this was fixed prior to beta release, no need for commonbugs.


Note You need to log in before you can comment on or make changes to this bug.