Bug 959796 - rngd.service attempts to start and fails - either should not have started or should succeed.
rngd.service attempts to start and fails - either should not have started or ...
Status: CLOSED DUPLICATE of bug 892178
Product: Fedora
Classification: Fedora
Component: rng-tools (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tony Camuso
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F19Blocker/F19FinalBlocker
  Show dependency treegraph
 
Reported: 2013-05-05 15:16 EDT by Robert Lightfoot
Modified: 2013-05-17 21:13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-17 21:13:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Lightfoot 2013-05-05 15:16:41 EDT
Description of problem:
rngd.service reports as failed contrary to qa test case

Version-Release number of selected component (if applicable):
4-3.fc19

How reproducible:
100%

Steps to Reproduce:
1. install from DVD
2. boot system
3. check systemctl --all --failed
  
Actual results:
rngd.service reports failed

Expected results:
service should succeed when started and start only if needed

Additional info:
systemctl status rngd.service output follows:
rngd.service - Hardware RNG Entropy Gatherer Daemon
   Loaded: loaded (/usr/lib/systemd/system/rngd.service; enabled)
   Active: failed (Result: exit-code) since Sun 2013-05-05 14:53:38 EDT; 11min ago
  Process: 399 ExecStart=/sbin/rngd -f (code=exited, status=1/FAILURE)
 
May 05 14:53:41 localhost.localdomain rngd[399]: Unable to open file: /dev/tpm0
May 05 14:53:41 localhost.localdomain rngd[399]: can't open any entropy source
May 05 14:53:41 localhost.localdomain rngd[399]: Maybe RNG device modules are not loaded
Comment 1 Igor Gnatenko 2013-05-15 04:40:23 EDT
Installed from DVD Beta TC4.
rngd.service - Hardware RNG Entropy Gatherer Daemon
   Loaded: loaded (/usr/lib/systemd/system/rngd.service; enabled)
   Active: active (running) since Wed 2013-05-15 08:16:53 MSK; 4h 22min ago
 Main PID: 524 (rngd)
   CGroup: name=systemd:/system/rngd.service
           └─524 /sbin/rngd -f

May 15 08:16:53 ThinkPad-X230.localdomain systemd[1]: Starting Hardware RNG Entropy Gatherer Daemon...
May 15 08:16:53 ThinkPad-X230.localdomain systemd[1]: Started Hardware RNG Entropy Gatherer Daemon.
Comment 2 Ankur Sinha (FranciscoD) 2013-05-15 05:16:22 EDT
On an up to date F19 machine:

[ankur@ankur-pc  ~]$ sudo systemctl start rngd.service
[ankur@ankur-pc  ~]$ sudo systemctl status rngd.service
rngd.service - Hardware RNG Entropy Gatherer Daemon
   Loaded: loaded (/usr/lib/systemd/system/rngd.service; enabled)
   Active: failed (Result: exit-code) since Wed 2013-05-15 18:25:53 EST; 1s ago
  Process: 11539 ExecStart=/sbin/rngd -f (code=exited, status=1/FAILURE)

May 15 18:25:53 ankur-pc systemd[1]: Started Hardware RNG Entropy Gatherer Daemon.
May 15 18:25:53 ankur-pc systemd[1]: rngd.service: main process exited, code=exited, status=1/FAILURE
May 15 18:25:53 ankur-pc systemd[1]: Unit rngd.service entered failed state.
[ankur@ankur-pc  ~]$


rng-tools-4-3.fc19.x86_64
Comment 3 Adam Williamson 2013-05-17 21:13:53 EDT

*** This bug has been marked as a duplicate of bug 892178 ***

Note You need to log in before you can comment on or make changes to this bug.