Bug 960295 - Can't compose email vm-user-agent with emacs 24
Summary: Can't compose email vm-user-agent with emacs 24
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs-vm
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Göran Uddeborg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-06 22:44 UTC by mpurtill
Modified: 2013-05-29 02:59 UTC (History)
2 users (show)

Fixed In Version: emacs-vm-8.1.2-2.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-28 00:58:02 UTC


Attachments (Terms of Use)

Description mpurtill 2013-05-06 22:44:12 UTC
Description of problem:

Doing C-x m, when I have user agent set to vm-user-agent, crashes

Version-Release number of selected component (if applicable):

emacs.x86_64 1:24.1-7.fc17
emacs-vm.x86_64 0:8.1.2-1.fc17

How reproducible: Every time


Steps to Reproduce:
1. emacs -q
2. M-x load-library vm
3. M-: (setq mail-user-agent 'vm-user-agent)
4. C-x m
  
Actual results:  Crash as above.  With debugging enabled, the traceback is:

Debugger entered--Lisp error: (wrong-number-of-arguments #[(&optional to subject other-headers continue switch-function yank-action send-actions) "<gibberish omitted>" [continue to subject buffer mail-header-separator other-headers vm-session-initialization vm-continue-composing-message vm-mail-internal format "message to %s" vm-truncate-roman-string 20 re-search-forward "^" "$" beginning-of-line 32 delete-char -1 58 ": " 10 "
" mail-position-on-field "To" "Subject" mail-text switch-to-buffer apply push-mark run-hooks mail-citation-hook mail-yank-hooks vm-mail-yank-default make-local-variable mail-send-actions switch-function yank-action send-actions] 7 nil nil] 8)
  vm-compose-mail(nil nil nil nil nil nil nil nil)
  compose-mail(nil nil nil nil)
  call-interactively(compose-mail nil nil)


Expected results:
VM compose mail buffer.

Additional info:
According to the bug <https://bugs.launchpad.net/vm/+bug/705393>, vm needs version 8.2.0b or later when used with emacs 24.

Comment 1 Göran Uddeborg 2013-05-14 10:02:50 UTC
I see the problem.  I also see reasons not to change this.  At least not in this stage of F17's life cycle.  8.2 is not completely compatible with 8.1, and I don't want to break anyone's usage in an update.  While this particular feature doesn't work, a lot of VM's functionality still is usable.

One could argue we should upgrade to 8.2 in rawhide and possibly F19.  I've not yet done that, since 8.2.0b is still officially a beta release.  I have been waiting for the final release.  Admittedly, it seems to take quite a long time for it to appear.  Hm...

Comment 2 Göran Uddeborg 2013-05-14 11:44:04 UTC
To know what to expect, I sent a question to the vm mailing list:

http://lists.nongnu.org/archive/html/viewmail-info/2013-05/msg00000.html

Comment 3 mpurtill 2013-05-14 16:59:18 UTC
FYI, I was able to fix the problem by just adding an additional argument (ignore-variable) to vm-compose-mail, like this (in /usr/share/emacs/site-lisp/vm/vm.el):

(defun vm-compose-mail (&optional to subject other-headers continue
		        switch-function yank-action
			send-actions ignore-variable)

After byte-compiling that, I was able to send email with vm.  I haven't found any other problems.

Comment 4 Göran Uddeborg 2013-05-14 20:53:26 UTC
Oh, it's that simple a patch!  (I never looked at what Uday had done.)

Let me also try it out a bit, and if it works for me too, I'll build an update.

Comment 5 mpurtill 2013-05-14 21:31:04 UTC
(In reply to comment #4)
> Oh, it's that simple a patch!  (I never looked at what Uday had done.)

Just to clarify, I'm not sure what the actual fix in the next vm version was either.  This was just my quick hack so I could send email.

Comment 6 Göran Uddeborg 2013-05-15 20:13:30 UTC
I see.  I took a look at what Uday had actually done.  He had added a bit more code, actually doing something with the new argument.

But it was still a very small patch.  And with a few lines of offset, it applied to 8.1.2 too.  So I'm trying to use that instead.  It seems to work fine initially.  If you wish to check your test cases too, my local build is available at ftp://ftp.uddeborg.se/pub/bz960295/emacs-vm-8.1.2-2.fc17.x86_64.rpm

Comment 7 mpurtill 2013-05-17 18:26:32 UTC
(In reply to comment #6)
> If you wish to check your test cases too, my local build is
> available at
> ftp://ftp.uddeborg.se/pub/bz960295/emacs-vm-8.1.2-2.fc17.x86_64.rpm

The vm in that rpm seems to work for me, thanks.

Comment 8 Göran Uddeborg 2013-05-17 21:20:18 UTC
Thanks for testing!  It seems to work for me too.  I'll go ahead and update the package in all branches.

Comment 9 Fedora Update System 2013-05-17 21:32:01 UTC
emacs-vm-8.1.2-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/emacs-vm-8.1.2-2.fc17

Comment 10 Fedora Update System 2013-05-17 21:53:04 UTC
emacs-vm-8.1.2-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/emacs-vm-8.1.2-4.fc18

Comment 11 Fedora Update System 2013-05-19 02:34:59 UTC
Package emacs-vm-8.1.2-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing emacs-vm-8.1.2-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8550/emacs-vm-8.1.2-2.fc17
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2013-05-19 20:51:50 UTC
emacs-vm-8.1.2-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/emacs-vm-8.1.2-6.fc19

Comment 13 Fedora Update System 2013-05-27 00:32:08 UTC
emacs-vm-8.1.2-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2013-05-28 00:58:02 UTC
emacs-vm-8.1.2-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2013-05-29 02:59:42 UTC
emacs-vm-8.1.2-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.