This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 960369 - (CVE-2013-2066) CVE-2013-2066 libXv: Array Index error leading to heap-based OOB write
CVE-2013-2066 libXv: Array Index error leading to heap-based OOB write
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20130523,repor...
: Security
Depends On: 966816 1078039
Blocks: 959130 1101912
  Show dependency treegraph
 
Reported: 2013-05-07 02:31 EDT by Huzaifa S. Sidhpurwala
Modified: 2014-10-17 03:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: libXv 1.0.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-16 02:21:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Huzaifa S. Sidhpurwala 2013-05-07 02:31:13 EDT
An Array index error leading to heap-based buffer OOB write flaw were found in the libXv, X.Org X11 libXv runtime library. When a X client is connected to a malcicious X server , (modified to return invalid values), it can cause arbirary code execution with the privileges of the user running the X client.

      Affected functions:  XvQueryPortAttributes()
Comment 2 Jan Lieskovsky 2013-05-23 11:52:28 EDT
Public via:
  http://www.openwall.com/lists/oss-security/2013/05/23/3
Comment 3 Huzaifa S. Sidhpurwala 2013-05-24 00:09:06 EDT
Created libXv tracking bugs for this issue

Affects: fedora-all [bug 966816]
Comment 4 Fedora Update System 2013-05-27 22:20:36 EDT
libXv-1.0.7-5.20130524git50fc4cb18.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Huzaifa S. Sidhpurwala 2013-06-04 23:41:19 EDT
This issue affects the version of libXv as shipped with Red Hat Enterprise Linux 5 and 6.
Comment 6 Huzaifa S. Sidhpurwala 2013-06-04 23:50:59 EDT
Statement:

This issue affects the libXv package in Red Hat Enterprise Linux 5. Red Hat Product Security has rated this issue as having Moderate security impact. This issue is not planned to be fixed in Red Hat Enterprise Linux 5 as it is now in Production 3 Phase of the support and maintenance life cycle: https://access.redhat.com/support/policy/updates/errata/
Comment 7 Fedora Update System 2013-06-05 21:32:54 EDT
libXv-1.0.7-5.20130524git50fc4cb18.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Jan Lieskovsky 2013-06-17 05:58:39 EDT
External References:

http://www.x.org/wiki/Development/Security/Advisory-2013-05-23
Comment 10 errata-xmlrpc 2014-10-14 01:05:49 EDT
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 6

Via RHSA-2014:1436 https://rhn.redhat.com/errata/RHSA-2014-1436.html

Note You need to log in before you can comment on or make changes to this bug.