This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 960523 - CMS formatted DASD drive causes anaconda crash
CMS formatted DASD drive causes anaconda crash
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
19
s390x Linux
high Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker 707037 fedora19rtt
  Show dependency treegraph
 
Reported: 2013-05-07 06:27 EDT by Jan Stodola
Modified: 2014-01-23 15:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 15:29:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
program.log (8.98 KB, text/plain)
2013-05-07 06:28 EDT, Jan Stodola
no flags Details
storage.log (32.08 KB, text/plain)
2013-05-07 06:28 EDT, Jan Stodola
no flags Details
vncserver.log (2.94 KB, text/plain)
2013-05-07 06:28 EDT, Jan Stodola
no flags Details
Blivet TB trying to init CMS disk (441.40 KB, text/plain)
2013-05-10 13:05 EDT, Brian Lane
no flags Details

  None (edit)
Description Jan Stodola 2013-05-07 06:27:17 EDT
Description of problem:
Anaconda crashes when a CMS formatted DASD drive is used during installation and user tries to create custom partitioning.

dmesg says:
...
[   76.556045] SGI XFS with ACLs, security attributes, large block/inode numbers, no debug enabled
[  259.313624] User process fault: interruption code 0x40009 in libparted.so.2.0.0[3fff5faa000+51000]
[  259.313943] CPU: 1 Not tainted 3.9.0-0.rc6.git2.4.fc19.s390x #1
[  259.313948] Process anaconda (pid: 890, task: 0000000033efcb00, ksp: 0000000033ed3a68)
[  259.313951] User PSW : 0705000180000000 000003fff5fce828 (0x3fff5fce828)
[  259.313990]            R:0 T:1 IO:1 EX:1 Key:0 M:1 W:0 P:1 AS:0 CC:0 PM:0 EA:3
User GPRS: 0000000000000200 0000000000000000 0000000000000000 0000000000000000
[  259.313995]            0000000000cf8400 00000000000067c2 000003fffff05538 00000000000067c2
[  259.313999]            0000000001257780 00000000928ef150 0000000093533f50 0000000000000019
[  259.314002]            000003fffd371000 000003fff5feb2c0 000003fff5fce60e 000003fffff051d0
[  259.314016] User Code: 000003fff5fce81a: eb120004000d        sllg    %r1,%r2,4
           000003fff5fce820: b9090012           sgr     %r1,%r2
          #000003fff5fce824: b90d0061           dsgr    %r6,%r1
          >000003fff5fce828: e310f0e00002       ltg     %r1,224(%r15)
           000003fff5fce82e: b9040037           lgr     %r3,%r7
           000003fff5fce832: e370f0a00004       lg      %r7,160(%r15)
           000003fff5fce838: 403070d2           sth     %r3,210(%r7)
           000003fff5fce83c: a7440047           brc     4,3fff5fce8ca
[  259.314042] Last Breaking-Event-Address:
[  259.314045]  [<000003fff5fce624>] 0x3fff5fce624


Version-Release number of selected component (if applicable):
parted-3.1-11.fc19.s390x
anaconda-19.21-1

How reproducible:
always

Steps to Reproduce:
1. format a DASD drive in CMS like this:
format 3161 f (blk 4k
2. start graphical (vnc) installation using the DASD drive (device number 3161 in this case)
3. go to the Installation Destination spoke
4. make sure the DASD drive is selected and click "Done"
5. click "Custom partitioning"
  
Actual results:
vnc session aborts, anaconda crashes

Expected results:
user can create custom partitioning

Additional information:
Filling against parted based on output from dmesg. I'm not sure if the issue can be reproduced using the parted command itself, since at least partition table can be displayed without any crash:

[anaconda root@rtt6 tmp]# parted /dev/dasda print
Model: IBM S390 DASD drive (dasd)
Disk /dev/dasda: 9847MB
Sector size (logical/physical): 512B/4096B
Partition Table: dasd
Disk Flags: 

Number  Start   End     Size    File system  Flags
 1      12.3kB  9847MB  9847MB

[anaconda root@rtt6 tmp]#
Comment 2 Jan Stodola 2013-05-07 06:28:17 EDT
Created attachment 744663 [details]
program.log
Comment 3 Jan Stodola 2013-05-07 06:28:22 EDT
Created attachment 744664 [details]
storage.log
Comment 5 Jan Stodola 2013-05-07 06:28:29 EDT
Created attachment 744666 [details]
vncserver.log
Comment 6 Brian Lane 2013-05-07 12:43:43 EDT
It should be possible to reproduce with the cmdline util, and it might give a better stack trace.
Comment 7 Dan Horák 2013-05-08 04:57:18 EDT
(In reply to comment #6)
> It should be possible to reproduce with the cmdline util, and it might give
> a better stack trace.

Wouldn't an image of the CMS formatted disk help? Or do you already have one?
Comment 8 Brian Lane 2013-05-09 11:28:28 EDT
Probably not, I think those code paths have to be run on s390.
Comment 9 Brian Lane 2013-05-09 13:26:36 EDT
When you hit this could you try running this from the cmdline:

parted -s /dev/dasda p
parted -s /dev/dasda mklabel dasd
parted /dev/dasda
mkpart

and go through the interactive mkpart (I am not sure exactly what it asks for dasd).

Hopefully you will hit a parted traceback.
Comment 13 Brian Lane 2013-05-10 13:05:22 EDT
Created attachment 746272 [details]
Blivet TB trying to init CMS disk
Comment 14 Jan Stodola 2013-05-13 04:18:47 EDT
Unfortunately, the crash is still reproducible, even with newer packages. Would you mind retrying the steps from comment 10 again on that machine?
Comment 15 Brian Lane 2014-01-23 15:29:04 EST
Anaconda and parted don't support partitioning un-partitionable devices.

Note You need to log in before you can comment on or make changes to this bug.