Bug 960549 - [RFE] Add option to submit private bugs
Summary: [RFE] Add option to submit private bugs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 19
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-07 11:26 UTC by Stephen Gallagher
Modified: 2015-02-01 22:55 UTC (History)
8 users (show)

Fixed In Version: gnome-abrt-0.3.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-15 00:54:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Stephen Gallagher 2013-05-07 11:26:34 UTC
Description of problem:
ABRT notifies the user that there may be sensitive data included in a coredump upload and asks them to approve submitting it as a bug. It would be better if ABRT also asked the user if they wished to make the bug private (set to the "Private Group") if they think it may contain sensitive information.

Version-Release number of selected component (if applicable):
abrt-2.1.3-2.fc19.x86_64

Comment 1 Jiri Moskovcak 2013-08-09 10:20:43 UTC

*** This bug has been marked as a duplicate of bug 803772 ***

Comment 2 Jiri Moskovcak 2013-08-09 10:25:23 UTC
Closed by mistake, this request is a bit different than the other bugzilla. ABRT doesn't ask user if they want to create the bug privately.

Comment 3 Jiri Moskovcak 2013-08-30 07:19:07 UTC
fixed in git:

commit c400b9d0011a1c6d978cc80aaf717c2fde802dfc
Author: Jiri Moskovcak <jmoskovc@redhat.com>
Date:   Wed Aug 21 10:40:05 2013 +0200

    ask user to create a private report if it contains sensitive data - rhbz#960549
    
    Signed-off-by: Jiri Moskovcak <jmoskovc@redhat.com>
    Signed-off-by: Jakub Filak <jfilak@redhat.com>

Comment 4 Fedora Update System 2013-09-13 13:09:31 UTC
gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19

Comment 5 Fedora Update System 2013-09-14 02:39:27 UTC
Package gnome-abrt-0.3.1-1.fc19, abrt-2.1.7-1.fc19, libreport-2.1.7-1.fc19, satyr-0.9-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-0.3.1-1.fc19 abrt-2.1.7-1.fc19 libreport-2.1.7-1.fc19 satyr-0.9-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16707/gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-09-15 00:54:26 UTC
gnome-abrt-0.3.1-1.fc19, abrt-2.1.7-1.fc19, libreport-2.1.7-1.fc19, satyr-0.9-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.