Bug 960568 - snmp-bridge-mib includes ifindex by the bridge it self
Summary: snmp-bridge-mib includes ifindex by the bridge it self
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: net-snmp
Version: 6.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jan Safranek
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-07 12:03 UTC by Dalibor Pospíšil
Modified: 2013-11-21 22:50 UTC (History)
1 user (show)

Fixed In Version: net-snmp-5.5-45.el6
Doc Type: Bug Fix
Doc Text:
In previous releases, snmp-bridge-mib subagent included the bridge itself as a port of the bridge in BRIDGE-MIB::dot1dBasePortTable. This is wrong and it has been fixed in this update, where snmp-bridge-mib subagent reports only real interfaces as ports in the BRIDGE-MIB::dot1dBasePortTable.
Clone Of:
Environment:
Last Closed: 2013-11-21 22:50:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1693 normal SHIPPED_LIVE net-snmp bug fix and enhancement update 2013-11-20 21:52:17 UTC

Description Dalibor Pospíšil 2013-05-07 12:03:18 UTC
Description of problem:
snmp-bridge-mib includes ifindex by the bridge it self.

Version-Release number of selected component (if applicable):
net-snmp-5.5-44.el6

How reproducible:
always

Steps to Reproduce:
1. execute linked test
  
Actual results:
snmpwalk returns interfaces attached to the bridge + brigde it self

Expected results:
snmpwalk returns interfaces attached to the bridge


Additional info:
This behavior does not appear in net-snmp-5.7.2 which is correct according to developer.

Comment 8 errata-xmlrpc 2013-11-21 22:50:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1693.html


Note You need to log in before you can comment on or make changes to this bug.