Bug 960601 - installer shouldn't allow setting a filesystem label for btrfs subvolumes
Summary: installer shouldn't allow setting a filesystem label for btrfs subvolumes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: newui-container
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-07 13:24 UTC by Chris Murphy
Modified: 2013-05-18 04:55 UTC (History)
8 users (show)

Fixed In Version: pykickstart-1.99.31-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-18 04:55:23 UTC


Attachments (Terms of Use)

Description Chris Murphy 2013-05-07 13:24:42 UTC
Description of problem:
In Manual Partitioning, the fields for naming various container types is non-obvious and inconsistent, and therefore confusing.

Version-Release number of selected component (if applicable):
anaconda 19.24-1

How reproducible:
Always


Steps to Reproduce:
Manual Partitioning UI.
  
Actual results:
Standard Partition:
- Name field is grayed out, set to /dev/sdXY.
- Label field is applied to the volume label, i.e. the label for the file system (e.g. mkfs.ext4 -L <volume-label>)

LVM:
- Name field is used to name the LVM Logical Volume.
- Label field is used for the volume label (the mkfs -L <volume-label>)
- Configure Volume Group, Name field is used to name the LVM Volume Group.

Btrfs:
- Name field is used to name the subvolume.
- Label field is available but apparently not used.
- Configure Volume, Name field, is used to name the volume label (the mkfs -L <volume-label>)

RAID:
- Name field is available but apparently not used, but causes crash, bug 960271.
- Label field is applied to the volume label (the mkfs -L <volume-label>)




Expected results (one possible example/suggestion):
Standard Partition:
- Device: /dev/sdXY (i.e. not a grayed out field) found where existing grayed out Name field is)
- Volume Label field (i.e. for the file system (e.g. mkfs.ext4 -L <volume-label>), relocate to be under the File System pop-up menu and indented to indicate it's a function of the file system.

LVM:
- Logical Volume Name field, found where existing Name field is.
- Volume Label field (i.e. for the file system (e.g. mkfs.ext4 -L <volume-label>), relocate to be under the File System pop-up menu, indented.
- Volume Group pop-up (i.e. no change here).

Btrfs:
- Subvolume Name field, found where existing Name field is.
- Label field ideally should be removed, graying out implies a label isn't possible/supported which it is, just elsewhere.
- Volume pop-up menu as it is now, but indented.



Additional info:
If UI freeze has happened, then I suggest graying the Label field when the device type is Btrfs, since the field is apparently not used for anything. Then rest bug to Rawhide and deal with polish in F20.

Comment 1 David Lehman 2013-05-14 15:23:45 UTC
The only change I could gather from the description that is planned is to prevent setting the label field for btrfs subvolumes, which will hopefully be in F19.

If you have ui design requests, please open a separate bug for those and include some annotated screenshots or mockups so the designers can see what you're talking about.

Comment 2 Fedora Update System 2013-05-15 22:25:31 UTC
anaconda-19.27-1.fc19, pykickstart-1.99.31-1.fc19, python-blivet-0.14-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.27-1.fc19

Comment 3 Fedora Update System 2013-05-16 05:21:56 UTC
Package anaconda-19.27-1.fc19, pykickstart-1.99.31-1.fc19, python-blivet-0.14-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.27-1.fc19 pykickstart-1.99.31-1.fc19 python-blivet-0.14-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8322/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.27-1.fc19
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2013-05-17 22:19:26 UTC
Package pykickstart-1.99.31-1.fc19, anaconda-19.28-1.fc19, python-blivet-0.14-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.31-1.fc19 anaconda-19.28-1.fc19 python-blivet-0.14-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8322/python-blivet-0.14-1.fc19,pykickstart-1.99.31-1.fc19,anaconda-19.28-1.fc19
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2013-05-18 04:55:23 UTC
pykickstart-1.99.31-1.fc19, anaconda-19.28-1.fc19, python-blivet-0.14-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.