Bug 960642 - An update notice is broken, or duplicate, skipping: messages
Summary: An update notice is broken, or duplicate, skipping: messages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: bodhi
Version: 19
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1008067 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-07 14:50 UTC by Orion Poplawski
Modified: 2016-09-20 02:44 UTC (History)
24 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-21 20:00:31 UTC


Attachments (Terms of Use)

Description Orion Poplawski 2013-05-07 14:50:26 UTC
Description of problem:

Getting messages like this hourly:

/etc/cron.hourly/0yum-hourly.cron:

An update notice is broken, or duplicate, skipping: FEDORA-2013-7321
An update notice is broken, or duplicate, skipping: FEDORA-2013-7323

Too much!

Comment 1 James Antill 2013-05-07 14:56:02 UTC
 This is due to the updateinfo on updates/updates-testing being different.

 On updates all the notices are marked as status=stable, but those exact same notices on updates-testing are marked as status=testing.

Comment 2 James Antill 2013-05-08 18:47:12 UTC
 So I just put a massive hack into upstream/rawhide/f19 yum to "solve" this on the yum side ... but the problem is actually worse than that, after solving the status problem there are still these left:

An update notice is broken, or duplicate, skipping: updates-testing/FEDORA-2013-1001
An update notice is broken, or duplicate, skipping: updates-testing/FEDORA-2013-2225
An update notice is broken, or duplicate, skipping: updates-testing/FEDORA-2013-0589
An update notice is broken, or duplicate, skipping: updates-testing/FEDORA-2013-0899

...the first 3 of which have different descriptions between updates/updates-testing, but the same ID. The last one has a slightly different "issued" timestamp (in theory I could hack workaround that too ... but I only really want to do that if you can't fix it on your end).

Comment 3 Orion Poplawski 2013-05-29 21:21:34 UTC
Can we get some movement on this please?  It's a real pain having all of my F19 test machines sending me an email every hour.

Comment 4 Luke Macken 2013-05-29 21:48:23 UTC
It looks like these are all cases where a testing update gets edited and replaced with newer versions, and bodhi doesn't properly prune them from the updateinfo, which it usually does.

Comment 5 Luke Macken 2013-05-30 14:46:16 UTC
I wrote a unit test that reproduces this warning message on F19, as well as a fix to avoid adding duplicate notices to the metadata.

https://github.com/fedora-infra/bodhi/commit/9c3c75f3171086ad2865f7477a716eda7abba490
https://github.com/fedora-infra/bodhi/commit/2815dabbb2fc5f08b08ef5a2dba57b9b02be2e7a

Comment 6 Luke Macken 2013-05-30 14:50:30 UTC
I just wiped out bodhi's repodata cache, which will force it to regenerate the updateinfo from scratch during the next push. This will fix your warnings in the mean time, until I deploy this fix to production.

Comment 7 Adam Williamson 2013-06-04 15:09:53 UTC
We got a mail to test@ complaining about one of these this morning, so I guess a new one has showed up.

Comment 8 Luke Macken 2013-06-04 18:13:59 UTC
I just pushed out a new version of bodhi to our releng machines, so hopefully this issue will be resolved after the next push.

Please re-open this bug if you see any more of those broken/duplicate update notice messages from yum.

Comment 9 Orion Poplawski 2013-06-06 19:13:52 UTC
Getting another now:

An update notice is broken, or duplicate, skipping: updates-testing/FEDORA-2013-10053

Comment 10 Luke Macken 2013-06-07 19:29:51 UTC
Thanks for catching this, Orion.

I made another attempt at avoiding duplicates: https://github.com/fedora-infra/bodhi/commit/8fcda84a24bf386ea005e45f20ca5250facbb2a7

My previous fix seemed to only fix the case where an update is edited and a single build is replaced with a newer version, where as the recent issues arose when an update is edited and new packages are added to it.

Hopefully this'll do the trick. I'll push this fix out to production today.

Comment 11 Luke Macken 2013-06-11 16:57:06 UTC
The latest fix has been in production for a couple of days now. Please reopen this bug if you see those duplicate update notice messages from yum again. Thanks!

Comment 12 Orion Poplawski 2013-06-26 20:02:22 UTC
New one:

Update notice FEDORA-2013-11685 (from updates-testing) is broken, or a bad duplicate, skipping.
You should report this problem to the owner of the updates-testing repository.

Comment 13 Luke Macken 2013-06-28 16:58:21 UTC
Looks like this is due to an edge case related to the handling of security updates in the update metadata.

I'm working on a fix and will get it deployed after our infrastructure freeze is over. In the mean time, I forced a regeneration of the updateinfo which will happen during the next push.

Comment 14 Orion Poplawski 2013-07-02 21:05:28 UTC
I don't know if this is the same kind of issue, but am now seeing:

Update notice FEDORA-2013-11662 (from updates-testing) is broken, or a bad

Comment 15 Orion Poplawski 2013-07-10 15:04:48 UTC
Also:

Update notice FEDORA-2013-12014 (from updates-testing) is broken, or a bad duplicate, skipping.

Comment 16 Orion Poplawski 2013-07-15 15:25:56 UTC
Another one: 

Update notice FEDORA-2013-12473

Comment 17 Luke Macken 2013-07-16 19:54:23 UTC
Hmm, looks like some of those aren't security related so my theory doesn't hold. I just pushed a patch to git that may solve the problem. If not, it'll have more useful debugging messages.

https://github.com/fedora-infra/bodhi/commit/42adfc63bb5335479a26087589d82e30ee12428d

Comment 18 Kevin Gardner 2013-07-17 19:28:33 UTC
Ditto to the last three that Orion reported, plus:

FEDORA-2013-12285
FEDORA-2013-12663

(all Update notices from updates-testing)


(In reply to Orion Poplawski from comment #16)
> Another one: 
> 
> Update notice FEDORA-2013-12473

Comment 19 Orion Poplawski 2013-07-25 16:07:56 UTC
So, in total I now have:


Update notice FEDORA-2013-13468 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-11662 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-12473 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-12663 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-12014 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-7077 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-12285 (from updates-testing) is broken, or a bad duplicate, skipping.

Comment 20 Orion Poplawski 2013-07-31 03:20:31 UTC
Seem to be down to one now:

Update notice FEDORA-2013-13577 (from updates-testing) is broken, or a bad duplicate, skipping.

Comment 21 Orion Poplawski 2013-08-05 15:24:54 UTC
New one today:

Update notice FEDORA-2013-14172 (from updates-testing) is broken, or a bad duplicate, skipping.

Comment 22 Greg` 2013-08-17 03:18:01 UTC
im also getting these warnings to when i try to look up ( updates-testing ) 

You should report this problem to the owner of the updates-testing repository.
Update notice FEDORA-2013-13577 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-14172 (from updates-testing) is broken, or a bad duplicate, skipping.

Comment 23 Thomas Spura 2013-08-18 15:54:57 UTC
Here, I get:
Update notice FEDORA-2013-14172 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-13577 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-14132 (from updates-testing) is broken, or a bad duplicate, skipping.

(Where the last one is new compared to the one reported from above.)

Comment 24 Greg` 2013-08-18 23:06:42 UTC
(In reply to Greg` from comment #22)
> im also getting these warnings to when i try to look up ( updates-testing ) 
> 
> You should report this problem to the owner of the updates-testing
> repository.
> Update notice FEDORA-2013-13577 (from updates-testing) is broken, or a bad
> duplicate, skipping.
> Update notice FEDORA-2013-14172 (from updates-testing) is broken, or a bad
> duplicate, skipping.

an update i now get all 3 errors 

Update notice FEDORA-2013-14172 (from updates-testing) is broken, or a bad duplicate, skipping.
You should report this problem to the owner of the updates-testing repository.
Update notice FEDORA-2013-13577 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-14132 (from updates-testing) is broken, or a bad duplicate, skipping.

Comment 25 Vadim Raskhozhev 2013-09-08 14:23:09 UTC
Same here with the following:

Update notice FEDORA-2013-13577 (from updates-testing) is broken, or a bad duplicate, skipping.
You should report this problem to the owner of the updates-testing repository.
Update notice FEDORA-2013-15734 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-15106 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-14132 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-14172 (from updates-testing) is broken, or a bad duplicate, skipping.

Comment 26 Frank McCormick 2013-09-18 15:39:16 UTC
The story continues ---

[frank@localhost ~]$ sudo yum check-update
Loaded plugins: langpacks, refresh-packagekit
Update notice FEDORA-2013-13577 (from updates-testing) is broken, or a bad duplicate, skipping.
You should report this problem to the owner of the updates-testing repository.
Update notice FEDORA-2013-15734 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-15106 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-14132 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-14172 (from updates-testing) is broken, or a bad duplicate, skipping.

Comment 27 Orion Poplawski 2013-09-18 16:46:08 UTC
So for FEDORA-2013-13577 it looks like it went to stable directly after being edited and a new build added.  The updates-testing debuginfo still has the old version.  It needs to be remove from updates-testing.

 bodhi - 2013-07-24 12:02:04
This update has been submitted for testing by andyp.
bodhi - 2013-07-24 15:40:23
This update is currently being pushed to the Fedora 19 testing updates repository.
bodhi - 2013-07-25 00:46:58
This update has been pushed to testing
bodhi - 2013-07-29 11:25:43
andyp has edited this update. New build(s): gfs2-utils-3.1.6-2.fc19. Removed build(s): gfs2-utils-3.1.6-1.fc19.
bodhi - 2013-07-29 11:25:57
This update has been submitted for testing by andyp.
bodhi - 2013-07-29 15:53:11
This update has reached the stable karma threshold and will be pushed to the stable updates repository
bodhi - 2013-07-29 21:04:16
This update is currently being pushed to the Fedora 19 stable updates repository.
bodhi - 2013-07-30 17:42:42
This update has been pushed to stable

Comment 28 Pascal94 2013-09-18 16:47:16 UTC
same for me :

[pascal@localhost~]$ sudo yum check-update
[sudo] password for pascal: 
Modules complémentaires chargés : langpacks, refresh-packagekit
adobe-linux-x86_64                                       |  951 B     00:00     
rpmfusion-free-updates                                   | 3.3 kB     00:00     
rpmfusion-free-updates-testing                           | 3.3 kB     00:00     
rpmfusion-nonfree-updates                                | 3.3 kB     00:00     
rpmfusion-nonfree-updates-testing                        | 3.3 kB     00:00     
updates/19/x86_64/metalink                               |  29 kB     00:00     
updates                                                  | 4.6 kB     00:00     
updates-testing/19/x86_64/metalink                       |  27 kB     00:00     
updates-testing                                          | 4.6 kB     00:00     
virtualbox                                               |  951 B     00:00     

Update notice FEDORA-2013-13577(depuis updates-testing) is broken, or a bad duplicate, skipping.
You should report this problem to the owner of the updates-testing repository.
Update notice FEDORA-2013-15734(depuis updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-15106(depuis updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-14132(depuis updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-14172(depuis updates-testing) is broken, or a bad duplicate, skipping.
[pascal@localhost~]$

Comment 29 Luke Macken 2013-09-19 22:30:42 UTC
I just pushed out a new version of bodhi to production, which may fix this issue. If not, I added many more debugging statements to this part of the code which will help me further track this issue down.

Comment 30 Orion Poplawski 2013-09-20 14:57:20 UTC
Today's crop:

Update notice FEDORA-2013-14132 (from updates-testing) is broken, or a bad duplicate, skipping.
You should report this problem to the owner of the updates-testing repository.
Update notice FEDORA-2013-17026 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-13577 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-15106 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-15734 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-17127 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-14172 (from updates-testing) is broken, or a bad duplicate, skipping.

Comment 31 Frank McCormick 2013-09-21 15:13:08 UTC
The latest ( Sat Sept 21-2013)

Update notice FEDORA-2013-14132 (from updates-testing) is broken, or a bad duplicate, skipping.
You should report this problem to the owner of the updates-testing repository.
Update notice FEDORA-2013-17026 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-13577 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-15106 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-15734 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-17127 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-14172 (from updates-testing) is broken, or a bad duplicate, skipping.

Comment 32 Frank McCormick 2013-09-23 14:48:52 UTC
Todays (Sept 23rd) batch


[root@localhost frank]# yum check-update
Loaded plugins: langpacks, refresh-packagekit
Update notice FEDORA-2013-15106 (from updates-testing) is broken, or a bad duplicate, skipping.
You should report this problem to the owner of the updates-testing repository.
Update notice FEDORA-2013-17373 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-14172 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-17026 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-17127 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-14132 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-13577 (from updates-testing) is broken, or a bad duplicate, skipping.
Update notice FEDORA-2013-15734 (from updates-testing) is broken, or a bad duplicate, skipping.
[root@localhost frank]# yum update

Comment 33 Luke Macken 2013-09-23 21:15:53 UTC
I wrote a little script that pulls in the updateinfo.xml from updates-testing, throws it at `yum.update_md.UpdateMetadata`, and checks it for duplicate IDs.

    https://gist.github.com/lmacken/6676152

Yum spit out the duplicate/broken error message, but it doesn't actually
contain any notices with duplicate update IDs.

This recent commit to yum added additional logic to compare two
notices using the new UpdateNotice.__eq__ method. 

    http://yum.baseurl.org/gitweb?p=yum.git;a=blob;f=yum/update_md.py;h=cf0b8827d9c45af76d5ac7070b29799c5801b1cc;hb=HEAD#l483

Looking closer at this new comparison method I discovered that "identical" update notices were actually failing this check because the 'issued' timestamps were different: '2013-09-22 03:08:42' != '2013-09-22 03:08:42.977048'.

I just committed this change to bodhi to properly format the timestamp, as
opposed to just using datetime.__unicode__. Hopefully that will prevent any extra precision from sneaking in.

    https://github.com/fedora-infra/bodhi/commit/43f4b8223fb2aee671029696e80d1af942fef12d

Infrastructure unfreezes on Wednesday, so I'll try and get this pushed out by then.

Comment 34 Luke Macken 2013-09-23 21:18:38 UTC
The yum commit I was referencing: http://yum.baseurl.org/gitweb?p=yum.git;a=patch;h=2ebc8ab8e9043985acb9da530af8269e1aafc446

Comment 35 Luke Macken 2013-09-28 05:03:42 UTC
I noticed another warning after today's push, which is due to the security update edge case that I mentioned in Comment #13. I'm working on a fix for this now.

Comment 36 Frank McCormick 2013-10-05 14:28:10 UTC
I haven't had any of these now for a few days. Hopefully fixed.

Comment 37 Luke Macken 2013-10-07 16:45:40 UTC
I hopefully fixed the last edge-case for this issue in https://github.com/fedora-infra/bodhi/commit/618d5de42c8377b4fbd56aa94122a20c6a3bc76e

Please re-open this bug if you see the yum warning again. Thanks!

Comment 38 Orion Poplawski 2013-10-10 02:33:15 UTC
New one:

Update notice FEDORA-2013-18382 (from updates-testing) is broken, or a bad duplicate, skipping.

Comment 39 Luke Macken 2013-10-10 23:59:02 UTC
Thanks Orion, I think I see what is happening.

I just pushed a few changes to git that will hopefully take care of the problem. I'll deploy it as soon as the current push finishes.

http://git.io/OxeLeQ

Comment 40 Frank McCormick 2013-10-14 00:17:48 UTC
Yum check-update today Sunday Oct 13

Update notice FEDORA-2013-18382 (from updates-testing) is broken, or a bad duplicate, skipping.
You should report this problem to the owner of the updates-testing repository.

Comment 41 Luke Macken 2013-10-14 17:36:40 UTC
My latest fixes went out to production yesterday. Please re-open this bug if you notice this warning from yum again.

Comment 42 Kevin Fenzi 2013-10-19 23:04:58 UTC
*** Bug 1008067 has been marked as a duplicate of this bug. ***

Comment 43 Harald Reindl 2013-10-30 00:00:47 UTC
> resolved as CURRENTRELEASE 

how comes?

[root@srv-rhsoft:~]$ date; yum check-update; date 
Mi 30. Okt 00:59:35 CET 2013
Geladene Plugins: etckeeper, protectbase, tsflags  
0 packages excluded due to repository protections
Update notice FEDORA-2013-19479 (von updates-testing) is broken, or a bad duplicate, skipping.
You should report this problem to the owner of the updates-testing repository.
Mi 30. Okt 00:59:44 CET 2013

-------- Original-Nachricht --------
Betreff: Re: Update notice FEDORA-2013-13577 (von updates-testing) is broken, 	or a bad duplicate, skipping
Datum: Wed, 30 Oct 2013 00:49:36 +0100
Von: Reindl Harald <h.reindl@thelounge.net>
An: devel@lists.fedoraproject.org

Am 14.09.2013 03:37, schrieb Theodore Lee:
> On 14/09/13 08:51, Reindl Harald wrote:
>> a few days ago i upgraded to F19 and my cron-script checking
>> for updates as well as "yum check-update" reports these
>> warnings - unsure where to report a bug because it's not
>> a specific package, so i post it here
>>
>> Update notice FEDORA-2013-13577 (von updates-testing) is broken, or a bad duplicate, skipping.
>> You should report this problem to the owner of the updates-testing repository.
>> Update notice FEDORA-2013-15734 (von updates-testing) is broken, or a bad duplicate, skipping.
>> Update notice FEDORA-2013-15106 (von updates-testing) is broken, or a bad duplicate, skipping.
>> Update notice FEDORA-2013-14132 (von updates-testing) is broken, or a bad duplicate, skipping.
>> Update notice FEDORA-2013-14172 (von updates-testing) is broken, or a bad duplicate, skipping.
> 
> Evidently this is a bodhi bug that's been around for a while, being
> tracked in bug 960642.[1]

and will this ever be fixed?

-------- Original-Nachricht --------
Betreff: Anacron job 'cron.daily' on srv-rhsoft.rhsoft.net
Datum: Wed, 30 Oct 2013 00:08:53 +0100 (CET)
Von: Anacron <root@srv-rhsoft.rhsoft.net>
An: root@srv-rhsoft.rhsoft.net

/etc/cron.daily/check-updates.cron:

Update notice FEDORA-2013-19479 (from-testing) is broken, or a bad duplicate, skipping. You should report this
problem to the owner of the-testing repository.

Comment 44 Kevin Fenzi 2013-10-30 00:19:10 UTC
reopening to investigate...

Comment 45 Germán Racca 2013-10-30 02:37:20 UTC
I'm getting this:

$ sudo yum --enablerepo=updates-testing check-update
...
Update notice FEDORA-2013-19479 (from updates-testing) is broken, or a bad duplicate, skipping.
You should report this problem to the owner of the updates-testing repository.

Comment 46 Luke Macken 2013-10-30 23:48:41 UTC
This latest one is due to a couple of bugs working together. First, bodhi was not properly purging updates from the testing metadata once they hit stable. It also wasn't regenerating notices for updates that have been edited. So with 2 update notices with the same ID in 2 different repos with different descriptions, yum gets confused and spits out that warning.

Today I refactored and simplified the updateinfo caching code and added more unit tests. We're frozen until next week, but I'll see what I can do about getting approval to deploy it before then, or at least flush bodhi's repodata cache to clear up the current ones.

https://github.com/fedora-infra/bodhi/compare/70d990e88436...221b57220564

Comment 47 Frank McCormick 2013-11-16 22:59:21 UTC
They're back !!

[root@localhost frank]# yum check-update
Loaded plugins: langpacks, refresh-packagekit
Update notice FEDORA-2013-20814 (from updates-testing) is broken, or a bad duplicate, skipping.
You should report this problem to the owner of the updates-testing repository.
Update notice FEDORA-2013-20736 (from updates-testing) is broken, or a bad duplicate, skipping.
[root@localhost frank]# 


First time today in a longtime.

Comment 48 Luke Macken 2013-11-21 15:42:15 UTC
I just pushed a new version of bodhi out that will hopefully fix this issue. Please re-open this bug if you notice this warning message again, thanks!

Comment 49 martingfernandez 2014-01-19 23:37:14 UTC
it is happening the same with RedHat version:
cat /etc/redhat-release 
Red Hat Enterprise Linux Workstation release 6.4 (Santiago)


Command: yum update -y

Output:
An update notice is broken, or duplicate, skipping: RHEA-2013:1774
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 285, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 219, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 498, in doTransaction
    problems = self.downloadPkgs(downloadpkgs, callback_total=self.download_callback_total_cb) 
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 2088, in downloadPkgs
    self.plugins.run('postdownload', pkglist=pkglist, errors=errors)
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 184, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/ibm-check-lotus-updates.py", line 259, in postdownload_hook
    ISLOTUSPKGSEC = isLotusUpdateSecurity( conduit, pkgtups )
  File "/usr/lib/yum-plugins/ibm-check-lotus-updates.py", line 83, in isLotusUpdateSecurity
    md_info.add(repo)
  File "/usr/lib/python2.6/site-packages/yum/update_md.py", line 528, in add
    if not self.add_notice(un):
  File "/usr/lib/python2.6/site-packages/yum/update_md.py", line 479, in add_notice
    seen.add(pkg['name'])
KeyError: 'name'

Comment 50 John Apple II 2014-01-20 02:44:40 UTC
I can confirm that I am seeing the same thing as in Comment 49 on a RHEL 6.4 box - same error for release RHEA-2013:1774 when I try a full upgrade and some single package upgrades.  and the exact same error message.

Comment 51 Thomas Spura 2014-01-20 08:57:57 UTC
The problem from Comment #49 seems to be something else (furthermore there seems to be some ibm plugin installed). I guess it would be best to open a separate bug for that...

Today it seems that kernel-3.12.8-300.fc20 was moved from updates-testing to updates, but wasn't deleted (yet?) from updates-testing and this warning appears:

# yum --enablerepo updates-testing check-update 
[snip]
Update notice FEDORA-2014-1062 (from updates-testing) is broken, or a bad duplicate, skipping.
You should report this problem to the owner of the updates-testing repository.

A "yum clean metadata" doesn't seem to help.

Comment 52 Luke Macken 2014-01-20 18:23:14 UTC
(In reply to Thomas Spura from comment #51)
> The problem from Comment #49 seems to be something else (furthermore there
> seems to be some ibm plugin installed). I guess it would be best to open a
> separate bug for that...

Yeah, that exception looks odd. I'm wondering if there is an IBM repo with some malformed updateinfo.xml in the repodata.

> Today it seems that kernel-3.12.8-300.fc20 was moved from updates-testing to
> updates, but wasn't deleted (yet?) from updates-testing and this warning
> appears:
> 
> # yum --enablerepo updates-testing check-update 
> [snip]
> Update notice FEDORA-2014-1062 (from updates-testing) is broken, or a bad
> duplicate, skipping.
> You should report this problem to the owner of the updates-testing
> repository.
> 
> A "yum clean metadata" doesn't seem to help.

I cannot reproduce this issue, are you still able to? I'm only seeing that kernel update in the stable metadata, not in the testing. Maybe this is a race condition between syncing the stable/testing repos to the mirrors?

I'm using this script to try and reproduce the issue: https://gist.github.com/lmacken/6676152

Comment 53 Luke Macken 2014-01-21 20:00:31 UTC
(In reply to martingfernandez from comment #49)
> it is happening the same with RedHat version:
> cat /etc/redhat-release 
> Red Hat Enterprise Linux Workstation release 6.4 (Santiago)
> 
> 
> Command: yum update -y
> 
> Output:
> An update notice is broken, or duplicate, skipping: RHEA-2013:1774
> Traceback (most recent call last):
>   File "/usr/bin/yum", line 29, in <module>
>     yummain.user_main(sys.argv[1:], exit_code=True)
>   File "/usr/share/yum-cli/yummain.py", line 285, in user_main
>     errcode = main(args)
>   File "/usr/share/yum-cli/yummain.py", line 219, in main
>     return_code = base.doTransaction()
>   File "/usr/share/yum-cli/cli.py", line 498, in doTransaction
>     problems = self.downloadPkgs(downloadpkgs,
> callback_total=self.download_callback_total_cb) 
>   File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 2088, in
> downloadPkgs
>     self.plugins.run('postdownload', pkglist=pkglist, errors=errors)
>   File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 184, in run
>     func(conduitcls(self, self.base, conf, **kwargs))
>   File "/usr/lib/yum-plugins/ibm-check-lotus-updates.py", line 259, in
> postdownload_hook
>     ISLOTUSPKGSEC = isLotusUpdateSecurity( conduit, pkgtups )
>   File "/usr/lib/yum-plugins/ibm-check-lotus-updates.py", line 83, in
> isLotusUpdateSecurity
>     md_info.add(repo)
>   File "/usr/lib/python2.6/site-packages/yum/update_md.py", line 528, in add
>     if not self.add_notice(un):
>   File "/usr/lib/python2.6/site-packages/yum/update_md.py", line 479, in
> add_notice
>     seen.add(pkg['name'])
> KeyError: 'name'


This is a different issue. Could you please open a new bug against RHEL for this? Thanks

Comment 54 Thomas Spura 2014-01-22 10:52:33 UTC
(In reply to Luke Macken from comment #52)
> (In reply to Thomas Spura from comment #51)
> > # yum --enablerepo updates-testing check-update 
> > [snip]
> > Update notice FEDORA-2014-1062 (from updates-testing) is broken, or a bad
> > duplicate, skipping.
> > You should report this problem to the owner of the updates-testing
> > repository.
> > 
> > A "yum clean metadata" doesn't seem to help.
> 
> I cannot reproduce this issue, are you still able to? I'm only seeing that
> kernel update in the stable metadata, not in the testing. Maybe this is a
> race condition between syncing the stable/testing repos to the mirrors?

It seems to. IIRC, stable/testing repos came from two different mirrors, so this is likely a race condition between the two. I don't think that can be fixed by yum or so...

Thanks!


Note You need to log in before you can comment on or make changes to this bug.