Bug 960661 - compiz hardly depends on libmatewnck and indirectly to other mate packages
Summary: compiz hardly depends on libmatewnck and indirectly to other mate packages
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: libmatewnck
Version: 18
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Dan Mashal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: depchain
TreeView+ depends on / blocked
 
Reported: 2013-05-07 15:28 UTC by Raphael Groner
Modified: 2013-05-08 13:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 960654
Environment:
Last Closed: 2013-05-08 13:09:52 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Xfce 7642 None None None Never

Description Raphael Groner 2013-05-07 15:28:17 UTC
+++ This bug was initially created as a clone of Bug #960654 +++

Description of problem:

# yum install --assumeno --enablerepo=updates-testing compiz-xfce |grep mate
--> Verarbeite Abhängigkeiten: libmatewnck.so.0()(64bit) für Paket: 1:compiz-0.8.8-19.fc18.x86_64
---> Paket libmatewnck.x86_64 0:1.5.1-1.fc18 markiert, um installiert zu werden
---> Paket mate-window-manager.x86_64 0:1.5.5-1.fc18 markiert, um installiert zu werden
 libmatewnck            x86_64    1.5.1-1.fc18         updates            405 k
 mate-window-manager    x86_64    1.5.5-1.fc18         updates            842 k


Version-Release number of selected component (if applicable):
compiz.x86_64 1:0.8.8-15.fc18

How reproducible:
yes

Steps to Reproduce:
1. install xfce spin
2. yum install compiz-xfce
3.
  
Actual results:
broken dependencies to enforce mate

Expected results:
no mate dependency. Don't fork libwnck!

Additional info:
Why did a fork of libwnck?

Comment 1 Christoph Wickert 2013-05-07 16:34:25 UTC
1. This does not count as a blocker. Please see https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process for more info.
2. The problem is in compiz or mate-window-manager, but definitely not in libwnck.
3. I have no idea why MATE forks libwnck, let's ask Dan. If there is a good reason, then having *mate*-window-manager depende on lib*mate*wnck makes sense and there is nothing to complain. Then we would just close this bug and focus on bug 960654.

Comment 2 Raphael Groner 2013-05-07 17:12:21 UTC
It does not make much sense to me have a general package named compiz that depends on special mate libraries. Maybe rename compiz to mate-compiz then. Compiz has been designed to work with other DE as well, like Xfce, LXDE, etc.

For me, clearly a violation of some official policy or agreed convention.

Comment 3 Wolfgang Ulbrich 2013-05-07 19:52:28 UTC
Dear xfce user,
I'm surprised that you do not perceive it as progress to have standard gtk-windows-decorator of compiz back.
But i can help you with your update pain.
I udate compiz and test it in a VM with xfce.

[root@localhost Arbeitsfläche]# yum localinstall compiz-0.8.8-20.fc20.x86_64.rpm 
Geladene Plugins: langpacks, presto
Untersuche compiz-0.8.8-20.fc20.x86_64.rpm: 1:compiz-0.8.8-20.fc20.x86_64
Markiere compiz-0.8.8-20.fc20.x86_64.rpm als eine Aktualisierung für 1:compiz-0.8.8-15.fc18.x86_64
Löse Abhängigkeiten auf
--> Führe Transaktionsprüfung aus
---> Paket compiz.x86_64 1:0.8.8-15.fc18 markiert, um aktualisiert zu werden
---> Paket compiz.x86_64 1:0.8.8-20.fc20 markiert, um obsoleting zu werden
---> Paket compiz-xfce.x86_64 1:0.8.8-15.fc18 markiert, um veraltet zu werden
--> Abhängigkeitsauflösung beendet

Abhängigkeiten aufgelöst

=========================================================================================================
 Package         Arch            Version                     Repository                            Größe
=========================================================================================================
Installieren:
 compiz          x86_64          1:0.8.8-20.fc20             /compiz-0.8.8-20.fc20.x86_64          4.8 M
     ersetzt  compiz-xfce.x86_64 1:0.8.8-15.fc18

Pls do not install forthcomming compiz-mate subpackage.

best regards

Comment 4 Wolfgang Ulbrich 2013-05-07 20:57:13 UTC
I forget to say.
Pls do not use compiz-gtk-windows-decorator subpackage in future to avoid mate dependencies.

Comment 5 Christoph Wickert 2013-05-07 21:03:51 UTC
1. Let us please not argue here.

2. This bug does have a "high" Severity as it doesn't match any of the criteria outlined at https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity

3. Raphael, if you state it's a "violation of some official policy", please be so kind as to state which policy you think was violated.

4. As I said I'd like to hear Dan's input. There may be valid reasons to fork and replace libwnck with libmatewnck. That's why I am reassigning the package (temporarily).

Dan, your input is appreciated.

Comment 6 Dan Mashal 2013-05-08 01:45:19 UTC
(In reply to comment #1)
> 1. This does not count as a blocker. Please see
> https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process for more info.
> 2. The problem is in compiz or mate-window-manager, but definitely not in
> libwnck.
> 3. I have no idea why MATE forks libwnck, let's ask Dan. If there is a good
> reason, then having *mate*-window-manager depende on lib*mate*wnck makes
> sense and there is nothing to complain. Then we would just close this bug
> and focus on bug 960654.

libmatewnck is a very important library for MATE and is a core library. MANY forked Gnome 2.32 packages were deprecated in MATE 1.6.

http://pkgs.fedoraproject.org/cgit/mate-desktop.git/plain/mate-desktop.spec?id=0438697c263ae8a991c237f5a5b745e16982fcdc

libmatewnck is required for MATE. As for compiz I have no idea.

IMHO we should create comps groups for compiz-mate and compiz-xfce

Comment 7 Raphael Groner 2013-05-08 08:11:50 UTC
(In reply to comment #5)
...
> 3. Raphael, if you state it's a "violation of some official policy", please
> be so kind as to state which policy you think was violated.

High	Problem due to crashes, loss of data, severe memory, leak, etc.
Medium	It's a bug that should be fixed eventually.

Though, we don't see a crash here but it's not a bug to fix "eventually". Make compiz (general) require mate libraries is doing loss of features to compiz, see my comment #2 above about other DE.

Comment 8 Dan Mashal 2013-05-08 13:09:52 UTC
(In reply to comment #7)
> (In reply to comment #5)
> ...
> > 3. Raphael, if you state it's a "violation of some official policy", please
> > be so kind as to state which policy you think was violated.
> 
> High	Problem due to crashes, loss of data, severe memory, leak, etc.
> Medium	It's a bug that should be fixed eventually.
> 
> Though, we don't see a crash here but it's not a bug to fix "eventually".
> Make compiz (general) require mate libraries is doing loss of features to
> compiz, see my comment #2 above about other DE.

Fix it then. Get to rioting some code and stop whining.

Under your logic anaconda should be dropped.

Enough of your tomfoolery.

Wolfgang worked very hard to get compiz working. If you don't like it don't install it. If you want to fix it email him offline and write some code.

Wolfgang, fix your deeps for XFCE and open a bug on comps and / or reassign this bug to comps and notting will take care of you. We can discuss on IRC if you need help.

Dan

Comment 9 Dan Mashal 2013-05-08 13:10:57 UTC
Rioting/writing* either way LOL


Note You need to log in before you can comment on or make changes to this bug.