Bug 960884 - Doubled clicks with logitech usb mouse
Doubled clicks with logitech usb mouse
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 05:03 EDT by Giovanni Campagna
Modified: 2013-09-20 10:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-20 10:35:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giovanni Campagna 2013-05-08 05:03:39 EDT
Description of problem:
I have a Logitech USB mouse, exposed as "Logitech USB Receiver" by evtest and "Logitech, Inc. Unifying Receiver" by lsusb.
Sometimes, quite often actually, single clicks are reported as double clicks in close succession.
This happens with xev and evtest, which makes me think it's a kernel issue.
Also, it happens with both buttons, so I don't think it's a hardware problem.

Version-Release number of selected component (if applicable):
kernel-3.9.0-301.fc19.x86_64

It was not happening (or was less frequent) with older 3.9 kernels. It was definitely not happening with 3.8

How reproducible:
It's random, most clicks go fine but some are wrong. Also, it happens that drags are terminated unexpectedly, even if the mouse is held down.
Comment 1 Josh Boyer 2013-09-18 16:31:40 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 2 Giovanni Campagna 2013-09-20 10:35:14 EDT
Sorry, I forgot to close this one, it turned out to be an HW failure instead.

Note You need to log in before you can comment on or make changes to this bug.