Bug 960886 - [RFE]Enhance the function "_cleanup_editing" for edit-node
[RFE]Enhance the function "_cleanup_editing" for edit-node
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 05:09 EDT by haiyang,dong
Modified: 2014-01-21 14:33 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.0-6.el6
Doc Type: Bug Fix
Doc Text:
Previously the edit-node function was not properly cleaning up temporary directories when finished.It failed to remove dd-isoXXX dir during cleanup.This has now been fixed so these files are removed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:33:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2013-05-08 05:09:41 EDT
Description of problem:
The purpose of the function "_cleanup_editing" for edit-node is cleaning up Configuration,
but right now, it didn't work well.
For example, after execute "edit-node --install-kmod kmod-tg3 --repo dd-tg3-13179-el6_2-x86_64.iso rhevh-6.4-20130415.0.el6_4.iso"
success,
check that:
[root@dhcp-9-245 ~]# mount
/root/dd-tg3-13179-el6_2-x86_64.iso on /var/tmp/dd-isoTinqfo type iso9660 (rw,loop=/dev/loop3)
/root/dd-tg3-13179-el6_2-x86_64.iso on /var/tmp/dd-isoNg9Bih type iso9660 (rw,loop=/dev/loop4)

[root@dhcp-9-245 ~]# ls /var/tmp/dd-iso
dd-iso08A9TE/ dd-isoEotdra/ dd-iso_LUleN/ dd-isoQEmEU3/ dd-isoXgI5TV/
dd-iso3WjE8n/ dd-isoEzrQg6/ dd-isomv6llh/ dd-isoqGvd3f/ dd-isoYm11Kq/
dd-iso42R6rl/ dd-isof6c2ag/ dd-isoNg9Bih/ dd-isoqtWjrZ/ dd-isoYQMxEx/
dd-iso73QPUn/ dd-isoG0dHy_/ dd-isonk9jbF/ dd-isorIGvvO/ dd-isoYu8vVr/
dd-iso8X1eCD/ dd-isoGFK4oc/ dd-isooAcbU1/ dd-isoslukG2/ dd-isoyV4Aw5/
dd-isoArqsSp/ dd-isoGgjRno/ dd-isoOe82yL/ dd-isosOc9SA/ dd-isoZMZpji/
dd-isoAVrvGq/ dd-isogRwzxz/ dd-isoOeK90B/ dd-isoTinqfo/ dd-isozrcyg4/
dd-isoD1KIx4/ dd-isoJfMcUx/ dd-isoPwJWSE/ dd-isoTkWulN/ 
dd-isoddArIN/ dd-isoKrcjww/ dd-isoQALDDr/ dd-isoVaBgxG/ 
dd-isoEaz0Vu/ dd-isolNhdyF/ dd-isoQczoR0/ dd-isoVMPcTo/



Version-Release number of selected component (if applicable):
ovirt-node-tools-2.5.0-17.el6_4.4.noarch

How reproducible:
100% 
 
Steps to Reproduce:


Actual result:          
                                                  
Expect result:
Enhance the function "_cleanup_editing" for edit-node to clean up Configuration completely.

Additional info:
Comment 5 haiyang,dong 2013-08-02 05:20:13 EDT
Test version:
ovirt-node-tools-3.0.0-6.1.el6.noarch
rhev-hypervisor6-6.5-20130725.0.el6 


Tested as follows:
edit-node --install-kmod kmod-tg3 --repo dd-tg3-13179-el6_2-x86_64.iso rhevh-6.5-20130725.0.el6.iso

After install kmod-tg3 success, check that dd iso temp dir is now unmounted and remove from /var/tmp/dd-isoXXXX during cleanup

so this bug has been fixed, change the status into "VERIFIED"
Comment 8 Cheryn Tan 2013-11-07 19:27:53 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 14:33:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.