Bug 9609 - user-mountable smbfs doesn't work
Summary: user-mountable smbfs doesn't work
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-20 16:45 UTC by Trond Eivind Glomsrød
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-27 12:00:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Trond Eivind Glomsrød 2000-02-20 16:45:35 UTC
Scenario:

The filesystem //foo/bar is specified in /etc/fstab as mountable on /bar,
with options "user,noauto".

This fails, because smbmount isn't installed setuid.

When this is fixed, the operation fails with message "failed to unmount
/bar" (this is not a partition, just an empty directory).

Comment 1 Bill Nottingham 2000-02-21 16:06:59 UTC
There are (last time we checked) a couple of races still in smbmount,
so it's not setuid.  The 'device or resource busy' is because
if the smbmount fails, the directory is left in a 'half-mounted'
state


Note You need to log in before you can comment on or make changes to this bug.