Bug 960933 - Multiple hibernate errors during initial startup of overlord console
Multiple hibernate errors during initial startup of overlord console
Status: CLOSED DUPLICATE of bug 947692
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Configuration (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Default User
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 06:41 EDT by George Varsamis
Modified: 2013-05-14 03:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 03:29:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Varsamis 2013-05-08 06:41:31 EDT
During initial login of the overlord console (gadget-web) the following errors appear (Note it doesn't happen on subsequent logins):
11:34:14,225 ERROR [org.hibernate.tool.hbm2ddl.SchemaExport] (http-/127.0.0.1:8080-6) HHH000389: Unsuccessful: alter table GS_PAGE drop constraint FK3EDCBE0268691C08
11:34:14,225 ERROR [org.hibernate.tool.hbm2ddl.SchemaExport] (http-/127.0.0.1:8080-6) Table "GS_PAGE" not found; SQL statement:
alter table GS_PAGE drop constraint FK3EDCBE0268691C08 [42102-168]
11:34:14,225 ERROR [org.hibernate.tool.hbm2ddl.SchemaExport] (http-/127.0.0.1:8080-6) HHH000389: Unsuccessful: alter table GS_USER_GROUP drop constraint FKABFBC21ED20070EC
11:34:14,225 ERROR [org.hibernate.tool.hbm2ddl.SchemaExport] (http-/127.0.0.1:8080-6) Table "GS_USER_GROUP" not found; SQL statement:
alter table GS_USER_GROUP drop constraint FKABFBC21ED20070EC [42102-168]
11:34:14,225 ERROR [org.hibernate.tool.hbm2ddl.SchemaExport] (http-/127.0.0.1:8080-6) HHH000389: Unsuccessful: alter table GS_USER_GROUP drop constraint FKABFBC21E68691C08
11:34:14,226 ERROR [org.hibernate.tool.hbm2ddl.SchemaExport] (http-/127.0.0.1:8080-6) Table "GS_USER_GROUP" not found; SQL statement:
alter table GS_USER_GROUP drop constraint FKABFBC21E68691C08 [42102-168]
11:34:14,226 ERROR [org.hibernate.tool.hbm2ddl.SchemaExport] (http-/127.0.0.1:8080-6) HHH000389: Unsuccessful: alter table GS_WIDGET drop constraint FK706A0F75EC27FD8
11:34:14,226 ERROR [org.hibernate.tool.hbm2ddl.SchemaExport] (http-/127.0.0.1:8080-6) Table "GS_WIDGET" not found; SQL statement:
alter table GS_WIDGET drop constraint FK706A0F75EC27FD8 [42102-168]
11:34:14,226 ERROR [org.hibernate.tool.hbm2ddl.SchemaExport] (http-/127.0.0.1:8080-6) HHH000389: Unsuccessful: alter table GS_WIDGET_PREF drop constraint FK1EFAB46BD6F8D9AD
11:34:14,226 ERROR [org.hibernate.tool.hbm2ddl.SchemaExport] (http-/127.0.0.1:8080-6) Table "GS_WIDGET_PREF" not found; SQL statement:
alter table GS_WIDGET_PREF drop constraint FK1EFAB46BD6F8D9AD [42102-168]
Comment 1 kconner 2013-05-08 09:23:32 EDT
This is different manifestation of https://bugzilla.redhat.com/show_bug.cgi?id=947692, should we combine them?
Comment 2 George Varsamis 2013-05-08 09:28:37 EDT
I think we should combine them. Its in the same component and most likely in the same file.
Comment 3 Gary Brown 2013-05-14 03:29:08 EDT
Yes it is the same underlying reason, which is explained by Jeff in https://bugzilla.redhat.com/show_bug.cgi?id=929206.

There is a separate bz related to changing the default H2 from in-memory to file based, which should cause these errors to only be produced on first startup.

*** This bug has been marked as a duplicate of bug 947692 ***

Note You need to log in before you can comment on or make changes to this bug.