Bug 960956 - SELinux is preventing /opt/google/chrome/chrome from 'create' accesses on the file libpeerconnection.log.
SELinux is preventing /opt/google/chrome/chrome from 'create' accesses on the...
Status: CLOSED DUPLICATE of bug 960792
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:fb1d799747ec487b476427d74cb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 07:25 EDT by Alexey I. Froloff
Modified: 2013-05-08 10:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-08 10:55:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey I. Froloff 2013-05-08 07:25:06 EDT
Description of problem:
Happens with google-chrome-unstable-28.0.1500.3-198635.x86_64

May be caused by upstream commiit http://git.chromium.org/gitweb/?p=chromium.git;a=commitdiff;h=57102aee28d22b6abd8356ed6959c915e7d5301e
File third_party/libjingle/overrides/initialize_module.cc

SELinux is preventing /opt/google/chrome/chrome from 'create' accesses on the file libpeerconnection.log.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that chrome should be allowed create access on the libpeerconnection.log file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep chrome /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                libpeerconnection.log [ file ]
Source                        chrome
Source Path                   /opt/google/chrome/chrome
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           google-chrome-unstable-28.0.1500.3-198635.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-92.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.8.11-200.fc18.x86_64 #1 SMP Wed
                              May 1 19:44:27 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-05-08 15:14:36 MSK
Last Seen                     2013-05-08 15:16:50 MSK
Local ID                      fe1ed713-dfa3-44a3-baef-cee74734e522

Raw Audit Messages
type=AVC msg=audit(1368011810.786:92): avc:  denied  { create } for  pid=2097 comm="chrome" name="libpeerconnection.log" scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file


type=SYSCALL msg=audit(1368011810.786:92): arch=x86_64 syscall=open success=no exit=EACCES a0=7ffbda1f08e8 a1=441 a2=1b6 a3=0 items=0 ppid=0 pid=2097 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=chrome exe=/opt/google/chrome/chrome subj=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 key=(null)

Hash: chrome,chrome_sandbox_t,user_home_dir_t,file,create

audit2allow

#============= chrome_sandbox_t ==============
allow chrome_sandbox_t user_home_dir_t:file create;

audit2allow -R
require {
	type chrome_sandbox_t;
	type user_home_dir_t;
	class file create;
}

#============= chrome_sandbox_t ==============
allow chrome_sandbox_t user_home_dir_t:file create;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.11-200.fc18.x86_64
type:           libreport

Potential duplicate: bug 960792
Comment 1 Daniel Walsh 2013-05-08 10:55:14 EDT

*** This bug has been marked as a duplicate of bug 960792 ***

Note You need to log in before you can comment on or make changes to this bug.