Bug 960983 - RHEVM-CLI: certificate file keys are not exposed in .rhevmshellrc
RHEVM-CLI: certificate file keys are not exposed in .rhevmshellrc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Juan Hernández
Ilia Meerovich
infra
: ZStream
Depends On:
Blocks: 969057
  Show dependency treegraph
 
Reported: 2013-05-08 08:59 EDT by Michael Pasternak
Modified: 2016-02-10 14:40 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The key_file, cert_file, and ca_file options can now be set in the rhevmshellrc configuration file.
Story Points: ---
Clone Of:
: 969057 (view as bug list)
Environment:
Last Closed: 2014-01-21 10:53:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15021 None None None Never
oVirt gerrit 15129 None None None Never

  None (edit)
Description Michael Pasternak 2013-05-08 08:59:45 EDT
Description of problem:

certificate file keys [1] are not exposed in .rhevmshellrc,

[1] key_file, cert_file, ca_file
Comment 2 Ilia Meerovich 2013-07-03 04:50:50 EDT
[root@ilia-rhevm ~]# rpm -q rhevm-cli
rhevm-cli-3.3.0.3-1.el6ev.noarch
[root@ilia-rhevm ~]# cat ~/.rhevmshellrc 
[cli]
autopage = True
[ovirt-shell]
username = 
timeout = None
extended_prompt = False
url = 
insecure = False
filter = False
session_timeout = None
ca_file = None
dont_validate_cert_chain = False
key_file = None
password = 
cert_file = None
[root@ilia-rhevm ~]#
Comment 3 Charlie 2013-12-12 20:11:27 EST
Hiya, does this need doc text? If what was the problem and the fix. Thanks.
Comment 6 errata-xmlrpc 2014-01-21 10:53:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0076.html

Note You need to log in before you can comment on or make changes to this bug.