Bug 960993 - [sanlock] Monitor and report the lockspace hosts liveness
[sanlock] Monitor and report the lockspace hosts liveness
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sanlock (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Teigland
Leonid Natapov
:
Depends On:
Blocks: 883504
  Show dependency treegraph
 
Reported: 2013-05-08 09:30 EDT by Federico Simoncelli
Modified: 2013-11-21 06:48 EST (History)
2 users (show)

See Also:
Fixed In Version: sanlock-2.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 06:48:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Federico Simoncelli 2013-05-08 09:30:24 EDT
Description of problem:
Sanlock should provide a way to monitor and report the lockspace hosts liveness.

Additional info:
An initial analysis has been made and it looks like the new C API will be sanlock_get_hosts which will return a list of active hosts with their status, e.g. alive, failing (killing the pids but not fenced by the watchdog yet), dead.

The python bindings will expose the same functionality with a function named get_hosts (sanlock module).
Comment 2 David Teigland 2013-07-01 18:05:58 EDT
Here is a sequence of commands to test the capability without the need for a separate test program.  It uses a shared vg "test" with a shared lv "test".


host1,2: service wdmd start
host1,2: service sanlock start

host1:
lvcreate -n test -L1G test
sanlock client init -s test:0:/dev/test/test:0

host1: sanlock client add_lockspace -s test:1:/dev/test/test:0
host2: sanlock client add_lockspace -s test:2:/dev/test/test:0

host1: sanlock gets -h 1
s test:1:/dev/test/test:0
h 1 gen 1 timestamp 1137100 LIVE
h 2 gen 1 timestamp 1136975 LIVE

(Note: exact timestamps will of course vary.)

host2: sanlock gets -h 1
s test:1:/dev/test/test:0
h 1 gen 1 timestamp 1137100 LIVE
h 2 gen 1 timestamp 1136975 LIVE

host2: killall -9 sanlock

Continue monitoring host2 from host1 by running sanlock gets.
After 80 seconds, host2 should appear in the FAIL state.
After 140 seconds, host2 should appear in the DEAD state.

host1: sanlock gets -h 1
s test:1:/dev/test/test:0 
h 1 gen 1 timestamp 1137573 LIVE
h 2 gen 1 timestamp 1137373 FAIL

host1: sanlock gets -h 1
s test:1:/dev/test/test:0 
h 1 gen 1 timestamp 1137634 LIVE
h 2 gen 1 timestamp 1137373 DEAD
Comment 5 Leonid Natapov 2013-08-29 03:55:19 EDT
sanlock-2.8-1.el6.x86_64, tested according to comment #2.
Comment 7 errata-xmlrpc 2013-11-21 06:48:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1632.html

Note You need to log in before you can comment on or make changes to this bug.