Bug 961024 - [RFE] Adding a content view to an activationkey should limit what subscriptions are available
[RFE] Adding a content view to an activationkey should limit what subscriptio...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: David Davis
Kedar Bidarkar
http://projects.theforeman.org/issues...
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 10:43 EDT by Og Maciel
Modified: 2017-02-23 16:20 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-19 20:14:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 7095 None None None 2016-04-22 12:18 EDT

  None (edit)
Description Og Maciel 2013-05-08 10:43:38 EDT
Description of problem:

If I have multiple providers with their unique products/repos and create and publish a content view that has only one of these products, when I add said content view to a new activationkey I expect that only the product added to the content view should be available to me in the Available Subscriptions tab. Currently, all products are listed as available for selection which to me is counter intuitive. I'd argue that only the one product that was added to the content view should be visible. If I removed the content view, then all available products can be displayed for selection.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 manjiri tapaswi 2013-07-15 18:41:39 EDT
Fixed 961024 - Limit available subscriptions for activationkeys by content view

PR: https://github.com/Katello/katello/pull/2634
Comment 4 manjiri tapaswi 2013-07-18 17:33:31 EDT
commit merged: c6be614
Comment 5 Brad Buckingham 2013-09-19 16:01:37 EDT
This bug was completed and should be available for QA.  Going to move to ON_QA.
Comment 6 Mike McCune 2013-10-17 16:58:46 EDT
Moving this to be tested during MDP3, not critical for MDP2 success story
Comment 8 Kedar Bidarkar 2014-04-28 09:14:20 EDT
This issue still persists

Tested with Sat6-Beta-Snap2,

1) Had multiple products with repos synced
2) Created a CV and added a repo
3) Published the CV version1
4) Promoted to Dev and then to Test
5) Moved to AK page and created a new ak with Test as env and CV as created in 2)
6) Moved to subscriptions, where all the products are still visible.


NOTE:- 

7) In CV we add repos and then publish/promote
8) But not sure why we see the entire products under AK's subscription page.
9) Wondering what happens when we have multiple repos under the product and only selected few are added to CV and published/promoted.
10) Will the systems/clients get access to all the repos under the product?
Comment 9 Mike McCune 2014-06-09 11:37:59 EDT
I do see products listed that do not exist in the environment selected in the activation key so this is definitely failing.


One thing to note thou is that you subscribe to products not repos.  The set of repos available to the client is determined by the ENV+CV you have selected for the AK (or via the registration process for the content host).

So if you only have 1 repo from a product in a CV in an env the system will only get access to that 1 repo.  They still need to consume a subscription from that product.
Comment 11 Partha Aji 2014-08-14 13:58:16 EDT
Created redmine issue http://projects.theforeman.org/issues/7095 from this bug
Comment 12 Tom McKay 2014-08-14 15:38:59 EDT
This is an RFE, not a bug. While it will be very useful to filter out subscriptions to those that match the content in the content view, there are some Red Hat subscription types that need to still be available.

1) Some subs have _no_ content at all but instead enable other subs.
2) Sometimes it is useful to assign a sub to a hypervisor, for example, so that "bonus" subs are created which in turn may be applied to guest hosts. These hypervisors don't actually consume content and thus may be in environments w/o any.

I'd suggest some design around this feature request:

UI - Perhaps add a filter element to the subs table to switch between all or content view limited.
CLI - Perhaps arguments to reflect same filter as UI.

Could be implemented as search?

Note that there is a related concept when assigning subs to content hosts as well and same design should be applied there as well.
Comment 13 Bryan Kearney 2014-08-19 20:13:26 EDT
Closing based on upstream discussions at https://github.com/Katello/katello/pull/4584. If you believe this was done in error, please re-open with your reasoning. Thanks!

Note You need to log in before you can comment on or make changes to this bug.